ShareReactor.ru: Поисковая система по файлообменным сетям - Статьи

Библиотека :: История развития файлообменных сетей

Зеленоглазый котенок и предложение купить футболку
на память — вот и все,что осталось от легендарного
Napster,если и не самой первой, то безусловно самой
популярной некогда пиринговой сети.

Peer-to-peer — "равный-равному", многовековой идеал самураев и социалистов-утопистов, был в самом конце второго тысячелетия воплощен в жизнь восемнадцатилетним бостонским студентом Шоном Фэннингом.

В январе 1999 года Шон по прозвищу Napster, проучившись всего один семестр, покинул Северо-восточный университет, для того чтобы полностью погрузиться в работу над программным обеспечением для нового проекта. Идея, над воплощением которой трудился мистер Фэннинг, была весьма незамысловатой и родилась в ходе общения с соседями по университетскому общежитию. Подключенным к Интернету меломанам, коих было немало среди друзей изобретателя, предлагалось "расшарить" на своем компьютере (то есть открыть для удаленного доступа других пользователей) директории с музыкальными файлами. А чтобы искать музыкальные композиции было легче, общий их список хранился на специальном центральном сервере, а сам поиск осуществлялся с помощью программы-клиента, которую должен был скачать каждый участник сети.

Недолго музыка играла...

Приведенная выше схема функционирования пиринговой сети является, конечно, сильно упрощенной, не учитывающей многих нюансов (например, временной недоступности отдельных участников сети). Тем не менее Шон Фэннинг, который, по его собственному признанию, учился программированию по ходу дела, успешно справился с возникавшими сложностями, и в начале лета того же года названная в честь своего создателя музыкальная сеть начала работу. Возможность бесплатного и простого (по сравнению, например, с FTP-архивами) получения интересующих композиций быстро обрела популярность, и по мере роста числа пользователей Napster и предлагаемых к обмену MP3-файлов привлекательность сети только возрастала.

Уже в августе 1999-го группа людей (в том числе и дядя Шона) вложили в проект серьезные деньги, которых должно было хватить еще на полгода, и один из инвесторов — Эйлин Ричардсон — стала в сентябре исполнительным директором компании Napster.

Хотя создатель Napster и его первые инвесторы были полны радужных надежд на будущее, а популярность проекта среди пользователей росла бешеными темпами, осень 1999-го, как выяснилось впоследствии, стала началом конца этой сети. В течение октября и ноября Napster ведет напряженные переговоры с представителями американской звукозаписывающей индустрии (RIAA). То ли возможность компромисса владельцами лейблов изначально не предполагалась, то ли всему виной была несговорчивость Эйлин Ричардсон, но, как бы там ни было, в начале декабря RIAA предъявила Napster ультиматум, грозя штрафами в сто тысяч долларов за каждый скачанный без ее разрешения музыкальный файл.

Карающая рука закона

Вся последующая история Napster состояла из отступлений и временных перемирий с владельцами авторских прав, что, впрочем, не мешало дальнейшему росту числа пользователей сети. В мае 2000 года по требованию рок-группы Metallica более 300 тысяч пользовательских компьютеров, содержащих ее песни, были исключены из пирингового обмена. Смена руководителя компании (обошедшаяся новому инвестору в 15 миллионов долларов) не спасла ситуации: в июне того же года RIAA сделала попытку наложить судебный запрет на все основные лейблы в коллекциях пользователей этой сети.Napster в ответ нанимает Дэвида Бойеса (адвоката, одержавшего победу над Microsoft в ходе затеянного правительством США антимонопольного разбирательства), Милтона Олина (бывшего топ-менеджера звукозаписывающей компании A&M) и объявляет о достижении договоренностей с компанией Liquid Audio, совместно с которой планировалось защитить музыкальный обмен от претензий поборников авторских прав. И все же 26 июля американский окружной судья Мерилин Пател постановила прекратить пиринговый обмен защищенными авторским правом композициями в течение двух суток. На этой интригующей ноте оставим на некоторое время многострадальный Napster наедине с американским правосудием и обратим свое внимание на его многочисленные аналоги.

Партизанская тактика обмена

После того, как популярность пирингового обмена стала очевидной, последователи Шона Фэннинга принялись писать свои собственные программы, стремясь превзойти прототип в удобстве использования, разнообразии доступных для обмена данных и защищенности от внешнего воздействия. В частности, в середине марта 2000 года в Интернете появилось программное обеспечение p2p-сети Gnutella, основанной на новой идеологии. В отличие от Napster, Gnutella не требовала наличия центрального сервера — вернее, функции сервера, обслуживающего запросы небольшой группы пользователей, мог выполнять компьютер любого участника пирингового обмена. Таким образом, блокировать работу сети отключением одного-единственного сервера стало невозможно. Любопытно, что авторы Gnutella Джастин Френкель и Том Пеппер являлись сотрудниками компании Nullsoft, принадлежащей крупнейшему провайдеру America-On-Line (AOL). Сама AOL в это же время готовилась к объединению с медиагигантом Time Warner, так что самодеятельность Френкеля и Пеппера была пресечена на корню. Однако джинн уже был выпущен из бутылки, и, несмотря на закрытие сайта http://www.gnutella.com/, копии программного обеспечения расползлись по Интернету. Как это нередко происходило и с компьютерными вирусами, независимые разработчики принялись усовершенствовать исходный код, породив многочисленные клоны Gnutella (из которых самыми популярными являлись Aimster, LimeWire, BearShare и Xolox).

Серьезную конкуренцию платформе Gnutella в скором времени составила технология голландской компании FastTrack. Разработанная почти одновременно с Napster, платформа FastTrack была не столь популярна вплоть до момента его первого официального закрытия. Так же как и Gnutella, основанные на FastTrack пиринговые сети (например, Morpheus, Grokster и KaZaa) не имели центрального сервера. Вместе с тем в качестве локальных серверов в данном случае выступали не любые, но наиболее мощные компьютеры из числа подключенных к p2p-сети, что значительно ускоряло ее работу. Ко всему прочему, программное обеспечение FastTrack позволяло объединять базы разных пиринговых сетей, увеличивая разнообразие доступных для скачивания файлов. Например, пользователи сети Morpheus (известной также под названием MusicCity), обогнавшей осенью 2000 года по популярности Napster, могли использовать ресурсы Grokster и KaZaa.

Мучения "котёнка"

Вернемся, однако, к Napster, апелляция которого была удовлетворена судом за считанные часы до предписанного срока закрытия. Вялотекущее судебное разбирательство продлилось до середины осени того же года, и к этому времени Napster в глазах владельцев авторских прав стал казаться меньшим злом по сравнению с конкурирующими сетями. Потенциальная уязвимость детища Фэннинга — наличие центрального сервера — позволяла организовать достаточно эффективную фильтрацию контента. Это обстоятельство, а так же огромная аудитория пиринговой сети (к концу 2000 года данным сервисом пользовались почти 40 млн человек) привлекли внимание немецкой медиакомпании Bertelsmann AG, и в конце октября было объявлено о достижении соглашения, в соответствии с которым на базе Napster планировалось создать платную службу музыкальной дистрибуции. Впрочем, сепаратный мир с Bertelsmann не избавил Napster от исков других звукозаписывающих гигантов, и агония p2p-сети продолжалась в течение всего 2001 года.

Могильщиками Napster стали не только поборники авторских прав, со многими из которых (в том числе и с Metallica) к лету 2001 года были достигнуты полюбовные соглашения, но также доброхоты, создававшие программы для обмана установленных пиринговой сетью фильтров (одна из таких программ была размещена, например, на сайте "напстероподобной" сети Aimster). Использовавшийся алгоритм идентификации MP3-файлов был весьма незамысловат и основывался на анализе их имен. Простая перестановка букв в именах файлов (типа MusicName =>usicNameM), не сильно затрудняющая визуальное опознание музыкальной композиции, оказалась не по зубам автоматическим фильтрам. И 11 июля 2001 года по формальному поводу (в связи с тем, что эффективность фильтрации защищенного авторским правом контента составляла не 100, а "всего" 99%) бесплатный файлообменный сервис Napster был закрыт окончательно.

Король умер, да здравствует король!

Для большинства поклонников бесплатной музыки этот день, видимо, не стал траурным. К моменту клинической смерти Napster количество доступных для скачивания через эту сеть композиций уменьшилось на 80%, тогда как конкурирующие проекты (американские Music City, Limewire, Bearshare и Audiogalaxy, голландская KaZaa, индийский Grokster, израильский iMesh и многие другие) активно расширяли базу пользователей. Впрочем, чувство безнаказанности, основанное в одних случаях на неподсудности европейских или, например, австралийских компаний американским судам, а в других — на неуязвимости децентрализованных сетей, подвело многих энтузиастов пирингового обмена.

Нерадостная тенденция упадка еще совсем недавно крупнейших файлообменных сетей рождает закономерный вопрос: а есть ли у технологий пирингового обмена будущее? Очевидно, что время, упущенное противниками свободного распространения информации в период рождения "Напстера", теперь играет им на руку. Конечно, полностью искоренить или даже значительно ограничить пиринговый обмен с помощью судебных запретов нереально (в силу уже упомянутых технических причин). Однако отсутствие легального статуса мешает владельцам p2p-сетей получать значительные инвестиции и не позволяет рассчитывать на крупные рекламные доходы. Одновременно с этим рекламный бизнес подрывают многочисленные неофициальные клоны клиентов пиринговых сетей, избавляющие пользователей от "назойливых баннеров". В результате компании банкротятся, и в лучшем случае на их раскрученных сайтах открываются платные музыкальные сервисы, а в худшем — домены могут достаться порнодельцам (по крайней мере, такое предложение было сделано в сентябре этого года почившему в бозе Napster).

Обмен под контролем

С точки зрения защитников авторских прав, пиринговые технологии могут с успехом использоваться в проектах, не затрагивающих напрямую их интересы и не конкурирующих с платными онлайновыми сервисами (например, для созданий сообществ людей, интересующихся проблемами типа поиска лекарств от рака). Другой интересной возможностью применения данных технологий является создание эффективных поисковых машин (над этой проблемой, в частности, работал покойный Джин Кан).

Вместе с тем, идея условно-бесплатного и одновременно легального распространения вполне коммерческого контента, как мне кажется, также имеет право на существование. Едва ли не основным аргументом защитников пирингового обмена является то обстоятельство, что достоверной связи между количественным ростом файлообмена и снижением официальных доходов от продажи контента (музыки на компакт-дисках, видео на DVD и т.д.) не наблюдается. Данные RIAA о падении доходов индустрии с этой точки зрения объясняются неблагоприятной общеэкономической конъюнктурой и медлительностью медиагигантов в отношении вывода на рынок новых продуктов. Более того, львиная доля тех, кто слушает скачанную в Интернете MP3-музыку, впоследствии покупает понравившиеся альбомы на CD ради их лучшего качества. И все же могут ли музыканты и их продюсеры заработать непосредственно на сетевом контенте, то есть согласится ли кто-нибудь платить за полученные в ходе пирингового обмена композиции?

Так быть или не быть?

Попробуем прежде ответить на другой, более общий вопрос: что обуславливает наличие стоимости у ресурса (товара, услуги)? Можно предложить два критерия наличия и величины стоимости:

  • Стоимость связана с редкостью ресурсов.
  • Стоимость проистекает из полезности товаров и услуг.

    В доцифровую эпоху подавляющее большинство предметов экономического оборота удовлетворяло одновременно обоим критериям. В дальнейшем, когда стоимость воспроизводства некоторых товаров значительно упала, мнения разделились. Так, звукозаписывающие гиганты придерживаются старой формулы, и им, естественно, выгодна относительная редкость контента. Их идеологические противники — адепты свободного распространения информации — считают искусственно создаваемую редкость анахронизмом и предлагают оценивать товары (услуги), исходя только из их полезности. Вознаграждение создателей цифрового контента в этом случае становится актом доброй воли потребителей и в ряде случаев обеспечивает последним дополнительную полезность (в виде расширенной функциональности или улучшенного качества зарегистрированных копий).

    К сожалению, отдельные попытки свободного распространения контента в Интернете (например, книги Стивена Кинга "The Plant") не дали удовлетворительных коммерческих результатов. С другой стороны, не в обиду мистеру Кингу будет сказано, сумма собранных таким образом средств должна существенным образом зависеть от потенциального спроса на товар.

    И что другое, кроме музыки, может быть востребовано огромной массой людей вне зависимости от их места жительства и — зачастую — языковых и культурных различий? Поэтому вполне возможно, что завтра пиринговые сети могут стать самой эффективной и даже небесплатной площадкой для раскрутки молодых исполнителей.

    А вот траурной майки своего любимого размера на сайте Napster я не нашел...

    • Автор: Дмитрий Вальяно
    Оригинал: www.kazaa.times.lv

    Библиотека :: Фильмы в интернете: где найти и как скачать.

    Итак, практика показывает, что не смотря на активное противодействие мультимедия кампаний в интернете полно развлекательного контента. Музыка, фильмы, клипы....

    Где же все это лежит? А лежит это все, дорогие друзья, у нас с вами на харддрайвах. Шумная заваруха вокруг Напстера сделала свое дело. Системы обмена файлами между пользователями очень популярны. Обмен файлами подразумевает непостредственный контакт одного пользователя и другого. Образцом такого общения является ICQ, там вы можете посылать сообщения и даже файлы напрямую другому пользователю. Давайте кратко рассмотрим ситуацию с двумя пользователями - А и Б которые хотели бы скачать друг у друга по файлу. Первое препятствие на их пути - это найти друг друга в интренете. Если А и Б дружат с дества, вместе работают, или как то общаются в "офлайн", то это не проблема, проблема если А не знает кого искать. Знает только что искать(например имя файла). В этой ситуации необходима некоторая программа, которая может "поделиться сведениями" о том, что Б готов отдать кому угодно некий файл. Эта программа должна быть расположенна в интернете и доступна всем. Фактически это сервер, к которому могут обращаться клиенты. Так работал Напстер. Всем пользователям раздавались клиенты, а сам Напстер держал у себя сервер. Клиенты сообщали о файлах пользователей, выложенных "на раздачу", сервер собирал эту информацию и делился ей (в виде результатов поискового запроса) с клиентами, эти запросы отправляющими.

    Напстер умер, попав под горячую руку, к тому же совершив серьезную ошибку, задавшись целью распространять в своей сети только музыкатьные файлы. По аналогичной схеме работают и другие службы (найти их можно по словам Peer to Peer File sharing) Приняв во внимание плачевный опыт Напстера, многие из них построены на распределенных серверах. Т.е. серверов много, и они обмениваются информацией друг с другом. Эта схема более живуча, особенно если и клиентское и серверное software распространяется свободно и бесплатно, а сами сервера разбросаны по всему миру.

    Вот одной из таких служб и является eDonkey2000 (В настоящее время вышел альтенативняй клиент для этой сети - eMule, и на сегодняшний день его использование является предпочтительным).

    Хочу подробнее остановится именно на этом сервисе, и обьяснить, чем же он отличается от других, аналогичных ему. Первое, на что надо указать (и о чем часто забывают праздношатающиеся в Инете пользователи) это истина -" в конечном счете за трафик кто то платит". Редко реализованы варианты www или ftp серверов, откуда вы можете скачать целые фильмы. Т.е отдать один фильм для 10 человек это порядка 7 гигабайт пропущенных по проводам. Поэтому, как только такой сервер становится достаточно известен - он умирает. В ситуации с ослом (edonkey, давайте так и будем его называть в дальнейшем) все совершенно наоборот. Чем больше народу скачивает сейчас один и тот же файл - тем лучше. Дело в том, что ослик бьет файл на небольшие дольки, и качает его из стольких источников одновременно, сколько доступно. Для популярных файлов всегда найдется десяток владельцев, и скорость скачивания будет часто ограничена только шириной вашего собственнного канала в Интернет. При этом, программа устроенна так, что на все время скачивания файла он доступен для скачивания другим. Клиентская программа позволяет вам указать какие фолдеры вы хотите расшарить(share - делить, разделять), и соотвественно какие файлы будут доступны для скачивания с вас. Однако файлы, которые находятся в процессе скачивания расшарены всегда, и вы не можете до нуля уменьшить скорость выкачки файлов от вас. Минимальное значение этого параметра 1 килобайт в секунду. При этом действует простое правило. Если вы устанавливаете upload speed =1 ваш download speed вудет принудительно выстален в 4, и так до 10килобайт. При аплоаде 10 килобайт в секунду и выше ваш - download не ограничен.

    Подведедем итог. Файл выложенный для распространения в ослик, легко разойдется по многим пользователям, и достаточно быстро, так как будет выкачитваться из многих источников.Кто то забрал 10 мег и при этом отдал другим 2.5 мега, этот в свою очеред отдает другим, и так по цепочке. Однако для 500 мегабайтного файла test.txt (который никому не интересен) этого сказать нельзя. Он будет, никому не нужный, лежать в одном экземпляре, и если кто то рискнет его скачать - то это будет достаточно меделенно. Вывод - качать нужно популярные файлы. Вывод два - название файла должно быть вразумительным. Принцип, по которому ослик выбирает источники для скачивания тоже достаточно разумен. Первыми заслуживают быть скаченными куски, которые наименее распространены. Т.е он стремится забрать именно то, что возможно исчезнет из сети.

    Следующий интересный факт - уникальность файлов. Вася Пупкин выкачал 2 серии фильма, переименовал их (ну не любит он, когда фильм назван английскими буквами) и выложил в ослик. Что произойдет? А ничего! Ослик не распознает файлы по именам. Фалы распознаются по их контрольной сумме , а имена служат только для поиска файлов. Итак, обнаружив новый файл в фолдере для share ослик произведет подсчет контрольной суммы(уникальное число для любого файла достаточно большого размера) и сравнит эту сумму с другими. Если такая же сумма будет найдена, то файл будет распознан, как копия, только переименованная, и будет использован как источник при скачивании другими. Причем контрольная сумма на файл, скаченный с помошью ftp, осла, или переданный от одного человека другому на CD, или любым другим способом без искажения информации будет всегда одинакова.

    Еще одно удобство - подача линков на файлы. Все привыкли кликать на линки. Вот этот приведет вас на windows версию клиента осла (наиболее свежий релиз на момент выкладывания статьи на сервер - v35.16.60) А вот такая ссылка выдаст ошибку в браузере. Однако если вы установите edonkey2000 или eMule и кликнете по этой ссылке, ослик подхватит линк и добавит в очередь закачек мультик Ну Погоди, 8 серия.

    Единственная, и главная проблема существующая в ослике это людской фактор - бывает так, что человек выложил файл, его скачали почти до конца, а владелец его убрал из расшаренных фолдеров. Так рождаются куски всегда недокачиваемых файлов. Для исключении такой ситуации достаточно иметь хотя бы один полный источник. Скорость уже не важна - надо чтобы этот файл был. Ну и сайты типа указанных выше форумов могут помочь в борьбе с такими ситуациями.

    Так что все, вступаем в ряды пользователей осла :-) Как минимум это даст вам возможность приобщиться к миру свободной информации - тип файлов который подерживается осликом ничем не ограничен. Поиск не слишком быстрый, но найти можно многое. Warez не исключение.

    На этом разрешите описательную часть закончить.

    Автор: Неизвестен
    Оригинал: www.ruvideo.com

    Библиотека :: eMule - новый шаг в развитии сети edonkey2000

    Многие из вас в последнее время заметили резкое снижение эффективности работы сети. Просто на глаз видно, что при сохранившейся скорости аплоада, скорость скачивания резко упала. Связано это, прежде всего, с ростом сети. Сервера не справляются с возложенными на них функциями, клиенты eDonkey также не были оптимизированны для работы в подобных условиях. Как обычно это и случается в интернет мире, если чего то не хватает, то очень вероятно, что это уже написали или пишут. С осликом случилась та же история. Устав ждать от автора милостей в виде обновлений морально и физически устаревшей версии осла, группа европейских программистов летом 2002 года занялась расшифровкой протокола работы edonkey и созданием собственного клиента для этой сети. В качестве базового языка был взят C++ от .NET, и проект стартовал как Open Source. Т.е исходные коды клиента распостранялись вместе с готовым exe файлом.

    Буквально за 2 летних месяца проект достиг стадии публичного тестирования и оброс основной функциональностью. В настоящее время скорость развития проекта стала ниже, но и основные возможности программы уже определены, идет процесс внесения улучшений, исправления багов, оптимизация. Мул использует стандартные для осла порты 4661-4665, которые должны быть открыты. Со старыми клиентами eDonkey он прекрасно работает, но несомненно, отдает предпочтение родственникам - мулам. Не могу назвать его идеальной заменой ослу, но по множеству параметров он уверенно обходит прародителя.

    Но по порядку - перечислим основные приемущества мула:

    Сервера:

  • возможность обновления списка серверов с заданных url при старте мула
  • возможность обновления списка серверов с заданного url во время работы и по таймеру (mods*)
  • возможность получения списка серверов не только от сервера, но и от клиентов, с которыми общается ваш мул
  • возможность форсировать реконнект к серверу в случае получения LowID
  • возможность сохранить "лучшие" сервера в специальном "постоянном" листе серверов, имеющем текстовый формат

    Клиенты:

  • рейтинговая система, обеспечивающая некий "паритет" между Upload and Download. Очередь клиентов, которые ожидают от вас доступа к файлам, движется в соответствии с рейтингом, скажем системы. Клиенты, которые отдали вам больше, двигаются быстрее. Рейтинг ведется не по ip адресу, а привязываетcя к конкретному клиенту /Надеюсь вернуться к более подробному рассмотрению рейтинговой системы позже/
  • клиенты обмениваются не только адресами серверов, но и списками сорсов для скачиваемых файлов. Таким образом заложена основа для безсерверной работы. К сожалению, клиенты с LowID не могут в полной мере воспользоваться всеми приемуществами безсерверной работы.

    Файлы для закачки:

  • теперь при старте мула происходит ReHash только тех файлов, которые изменились с момента последнего выхода из программы. Т.е можно рестартовать мула так часто, как хочется, не нарываясь на получасовой процесс пересчета контрольной суммы для тех 10 гигабайт файлов, которые стоят в очереди на закачку.
  • Источники для скачиваемых файлов теперь сохраняются на диске. Т.е. после рестарта мула, еще до коннекта к серверу ваш клиент может начинать опрос источников именно нужного вам файла.
  • скопировать "ed2k://" линк можно прямо в списке качаемых файлов.
  • встроенная функция предпросмотра фильмов, если скачены куски с началом и концом фильма.
  • для предыдущего пункта реализована возможность пытаться скачать эти куски прежде всего.
  • Скорость вашего Upload может быть разбита на примерно равные куски между заданным числом качающих. Т.е. ваши 30 килобайт аплоада будут разделены на 10 человек по 3 килобайта каждому, а не на 30 по 1 (mods*) вплоть до задания на сколько человек или по какой скорости нарезать.
  • клиент показывает не только скорость, с которой вы качаете каждый файл, но и скорость скачивания с каждого конкретного источника. (mods*) и на каком месте в очереди вы стоите у искочника, с которого пока не качаете.
  • можно посмотреть не только очередь уже качающих, но и тех, кто стоит к вам за файлами(и за каким). И эта очередь не ограничена 50 как в осле.
  • автоматический приоритет редких в сети файлов (mods*)
  • при передачи от мула к мулу блоки могут сжиматься, что дает выигрыш в размере переданного файла.
  • Интеллектуальный механизм проверки контрольной суммы позволяет в случае обнаружения битого блока перекачивать не весь 9Мб блок, а только его часть.

    Shared файлы:

  • возможность задать приоритет и здесь, вплоть до приоритета "Релиз", который будет форсировать вашу программу отдавать этот файл в первую очередь.
  • Там же можно посмотреть статистику - как скачивают этот файл. На мой взгляд, в этой статистике все неверно, но надеюсь, что эту багу поправят рано или поздно.

    Поиск:

  • поиск может быть глобальным, по всем серверам или только по текущему серверу,
  • там же, в окне поиска можно поставить файл на закачку, указав его "ed2k://" линк,
  • (mods*) реализован поиск по всем известным серверам с использованием web движков.

    Общее:

  • приятный интерфейс, и никакой рекламы
  • поддержка разных языков, в том числе и русского
  • достаточно полная статистика о том, что происходит - скорости Upload и Download, средние скорости, количество использованных сокетов, графики.
  • встроенный IRC клиент

    Сноска (mods*) означает, что возможность может быть не реализована в официальном emule, а реализована в одной или нескольких модификациях клиента. Причем, так как код клиента открыт, то штучки, реализованные в модах, и вызвавшие одобрение пользователей переползают в основной базовый клиент довольно быстро. Форум модов мула есть здесь http://www.emule-project.net/ - далее eMule-Board ->Development ->eMule Mods

    Это я привел список наиболее общих изменений по отношению к edonkey клиенту. Как написано выше - существует достаточно много модификаций клиента, базирующихся на достаточно свежей официальной версии. В этих модификациях сторонние программисты пробуют свои силы в изменении отдельных возможностей программы. Большая часть из них направлена на попытку дать пользователю большую власть над настройками процесса ul/dl и интерфейса. Есть моды, более жестко регламентирующие рейтинги клиентов, т.е "ты мне ничего не отдал, а скачал уже 10 мег - я тебе больше не дам". Есть системы, ориентированные на определенную комьюнити, отдающие приоритет в первую очередь клиентам из этой комьюнити. Собственно активно развивающихся модов порядка десятка. Из них 2-3 наболее активных и продвинутых. По показаниям статистики более половины ослинной сети сейчас использует мул в качестве клиента.

    Теперь пару слов о рейтинговой системе в базовом муле . Собственно рейтинг стоится на основании нескольких факторов, таких как:

  • тип клиента (мул/не мул)
  • LowID / HighID
  • сколько уже скачал с меня /Сколько отдал мне
  • сколько времени стоит в очереди
    комбинация этих параметров дает возможность даже новичку в сети, постояв в очереди, начать что-то скачивать.

    Ну, и напоследок то, что в муле пока реализовано плохо:

  • Первое и наиболее часто возникающее нарекание - безобразная работа под LowID - если ваш комп за файрволом, или NAT сервером, вы не можете рассчитывать на высокую скорость DL Так было и с ослом, но мул ухитряется плохо работать даже на раздачу из под LowID.
  • Второе нарекание - мул активно работает с сокетами, действительно активно. И при большом количестве коннектов негативно влияет на работу старых win9X систем. Возможно пользователям 95-98 виндов все же стоит подумать об обновлении системы до win2000 или winXP.
  • Третье, и последнее - падает он временами. Не у всех, не всегда и не все время. Однако временами случается...
    Несомненно другие пользватели мула могут дополнить этот ряд недостатков своими претензиями. Но это наиболее общие...

    Вот, коротенько о муле как таковом, и о том, что он нам может предложить. Переходить ли на него - решать вам. Я перешел. Уже с сентября. Не жалею.

    Если надумаете - мула можно поставить в отдельную директорию, скопировать в нее known.met и server.met из директории осла, запустить мула (осел должен быть выгружен) и указать ему фолдер с временными файлами и фолдер, куда класть скаченное - те же, что вы использовали для осла. Мул сразу начнет скачивать недокаченное ослом.

    Удачи вам в выпасении мула :-)

    Автор: Неизвестен
    Оригинал: www.ruvideo.com

    • Библиотека :: Помощь в настройке eMulePlus для ословодов-чайников.

    1. Вступление

    При пользовании версиями простого мула 0.23-0.27 отмечал разные положительные и отрицательные моменты в настройках и раздаче расшаренных файлов, но считал до сих пор ненужным придавать особое внимание разным модам (мод - разновидности/модификаций), теперь решил попробовать и был приятно удивлён.

    Рассмотреть более подробно решусь лишь вышеуказанный мод, так как их очень много на все времени не хватит, кроме того после досконального изучения описаний и мнений пользователей пришёл к выводу что данный мод является оптимально корректным с малым содержанием ошибок, развивается довольно шутсро и особенно интересен для желающих "правильно и быстро раздать".

    Данный текст расчитан как на бывалого ословода, так и на полнейшего новичка в этом деле. Ословодами называются пользователи eDonkey, eMule, mlDonkey и их разновидностей (модов). Статья содержит картинки и может быть использована в качестве наглядного пособия при установке и использовании eMulePlus, предполагаются знания в включении и выключении персонального компьютера.

    2. Кто такой eMulePlus ?

    Прямым предком является eMule, который в свою очередь потомком eDonkey2000 и породил собою новый пользовательский интерфейс (gui - graphical user interface), отличается стабильностью, удобствами и более интуитивным расположением функций.

    На сайте разработчика можна найти линки на Installer, Binary и Sources. Разберём по порядку:

    - Installer - это то что нам нужно, так называемый помощник установки (wizard), который помогает Вам выбрать путь для программы(приложения), прописать в реестре нужные ключи и выбрать тип базовой конфигурации;
    - Binary - содержит все нужные для запуска приложения файлы и позволяет ручную установку, запакован в ZIP-архив, интересен для более продвинутых пользователей и когда хочешь просто испробовать прогу без нагружения реестра всякими записями, которые иногда приходится удалять вручную;
    - Sources - так же ZIP-архив, содержит проэкт исходного кода программы (исходники) на языке программирования С++ в среде разработчика Visual C++ .NET от Microsoft. EMulePlus как и его прямые и косвенные прородители является OpenSource проэктом, что означает не только то что в исходники могут заглянуть все, но и то что любой может активно или пассивно участвовать в разработке, тестируя и сообщая об ошибках, исправляя ошибки и развивая (имплементируя) новые фишки (features).

    Тут можна найти перечень более-менее известных модов и прочую полезную или не очень информацию касательно p2p-файло-обменовых-сетей.

    3. Тянем eMulePlus

    Тянуть будем с сайта разработчика, а не с mirrors (дружественные сайты, предоствляющие возможность стянуть какой-либо файл со своего сервера), жмём на Donwload from SourceForge

    мы попадаем в download-раздел и жмём на ту версию инсталлера, которую мы хотим стянуть, на данный момент (04/07/2003) актуальна версия 1с

    выбираем нужную нам ссылку и нажимаем на неё

    попадаем на выбор mirror* (* - см. выше) и выбираем ближайший к нам сервер, в зависимости от географического положения, жителям западной европы советую швейцарию и бельгию (маркированы), выбрав желаемый сервер делаем click (левай кнопка мышки) как это указано на следующей картинке

    страница перезагружается и после пару секунд ожиданию запустит автоматически окно запроса на скачивание файла* , в котором мы выбираем Save (Сохранить)

    *- внимание: пользователи менеджерами загрузки как Download Accelerator Plus, ReGet, GetRight и т.д., у Вас скорее всего запустится менеджер

    выбираем в окне запроса месторасположения папку в которой хотим сохранить файл и нажимаем Save (Сохранить)

    файл тянется

    после завершения ...

    4. Установка - запускаем помощника установки (wizard)

    находим стянутый нами файл и путём двойного клика запускаем wizard

    первое окно, спрашивает нас хотим ли мы установить eMulePlus, отвечаем утвердительно и нажимаем Yes (Да)

    нас приветствует wizard, нажимаем Next (Далее)

    нас просят прочитать условие договора конечного пользователя и подтвердить своё согласие, мы чиаем до конца договор и если кое-что понимаем то соответственно соглашаемся с условиями, в противном случае просто нажимаем на Yes (Да)

    в следующем окне мы выбираем, папку в которой программа будет сохранена для дальнейшего использования, стоит согласиться с по умолчанию предложенной папкой и нажать Next

    далее нам предлагается к выбору запись в стартовом меню, мы так же можем используем по умолчанию предложенную запись и нажимаем Next (Далее)

    в след. окне мы выбираем хотим ли мы получить ярлык-ссылку на Рабочем месте (Desktop) и в меню быстрого доступа (Quick Launch)

    - Quick Launch

    теперь нам осталось лишь подтвердить выбранные нам опции и установка начнётся, для етого нажимаем на Install (Установить)

    подтверждаем завершение и отмечаем опцию запуска программы

    5. Запускаем eMulePlus

    После установки программа запускается автоматически сама (если она не запустилась, запустите её путём нажатия на ярлык в меню быстрого доступа), если мы отметили ето опцию, с первым окном мы получаем сообщение что программа выбрала по умолчанию язык нашей системы, но мы можем ето позже изменить, мы нажимаем на ОК

    далее программа спрашивает нас, хотим ли мы разрешить использование нескольких инстанций eMule Plus, т.е. будем ли мы одновременно стартовать 2 или более программ eMule, при этом программа будет при старте спрашивать у системы имеются ли запущенными какие либо eMule Plus приложения*, если такие имеются, то она в зависимости от вашего выбора запустится или нет. Мы выбираем No (нет).

    Примечание: данна опция интересна участникам релиз-групп, т.к. они запуская паралельно мула с другими настройками могут проверить кол-во источников.

    * - хочу отметить что в момент моего запуска у меня была загружена инстанция eMule v0.26c и eMulePlus не запустился, ибо я дал изначально негативный ответ на вопрос о нескольких eMule Plus, что говорит о том что разработчики eMulePlus либо неправильно поставили вопрос, а именно точнее было бы "Разрешать запуск нескольких eMule", либо они неправильно имплементировали функцию проверки активных инстанций.
    Используя язык простого пользователя: при ответе "No", Вы не сможете запускать ету программу, если какая либо другая версия eMule уже запущена.

    И так мы запустили нашего Мула+ и если мы всё делали правильно, то увидим след. окно

    несмотря на то что мы ещё не соединялись с сервером, мы имеем список известных серверов (server.met), оказывается разработчики мула+ решили облегчить чайникам жизнь и дать возможность не искать списки активных серверов, как ето делают разработчики простого мула, а предоставить список с активными серверами.

    6. Конфигурация

    а) Добавляем новый сервер

    Для начала добавим русский сервер* нижне-новгородского ословодческого хозяйства, для етого в закладке Сервер (Server), нажимаем на кнопку [image] (Add new server) и получаем окно, поля которого заполняем след. образом

    и нажимаем Добавить (Add), запись должна появиться в листе серверов, так как мы хотим часто пользоваться этим сервером, нам стоит занести его в список постоянных серверов, для етого мы выбираем етот сервер из списка и правой кнопкой мышки вызываем popup-меню и выбираем позицию "Добавить в постоянный список серверов"

    теперь мы можем приступить к настройке.
    *сервер - сервера нужны для обмена инфорацией между серверами и клиентами о разшаренных файлах, сети типа Gnutella (Kazzaa, Napster итп) таких серверов не имеют, чем и проигрывают сетям с управляющим елементом, в сетях DC++ такой элемент называется хабом (hub).

    б) Настройка

    Итак после успешной установки перейдём к самому важному пункту счастливого ословода - конфигурации мула+, для етого мы нажимаем на закладку "Настройка" в панеле закладок мула

    - панель закладок.

    Нашему взору открывается окно настроек, оглавление "Общие", важные на мой взгляд настройки отмечены цветами

    Имя (Nick)
    Вы можете указать ваше имя, под которым вас будут видеть другие пользователи. Выберите себе имя по усмотрению, важно добавить (rus) приставку в вашем имени, чтобы вас пропустил нижне-новгородский сервер.

    Язык (Language)
    Вы можете выбрать язык интерфейса программы, мы остаёмся с русским и улыбаемся тем у кого такой возможности нет :)

    Глубина 3D (3D Depth)
    Это настройка способа отображение линеек на которых вы видите процесс приема/передачи. Этот регулятор ступенчато меняет способ отображения этих линеек - от "выпуклого" псевдо 3D до обычного плоского изображения.

    Редактирование веб-служб (Edit Webservices)
    Откройте для редактирования файла webservices.dat. В нем перечислены ссылки которые вы можете вызвать используя пункт меню "Веб-службы". Более подробное рассмотрение функции на данный момент не готово.

    Звуковой сигнал при ошибке. (Beep on errors)
    Когда возникает ошибка в работе (отсоединение от сервера, проблема с хэшированием* файла) система предупредит вас об этом звуковым сигналом.
    *хеширование - для передачи информации серверу о разшариваемых файлах, мул создаёт уникальное число описывающее файл.

    Показывать логотип (Show Splashscreen)
    Разрешить/запретить показывать логотип при каждом запуске программы.

    Разрешить запуск нескольких eMule Plus (Allow multiple instances of eMule)
    Эта настройка разрешает вам запускать несколько копий eMule на одном компьютере.(Важно! Проверьте чтобы запускаемые копии были установлены в разные каталоги и чтобы в настройках было указано использовать разные порты).

    Включить онлайн-подпись (Enable Online-Signature)
    Эта настройка разрешает использовать ваши данные в подписи. Файл с вашими данными (onlinesig.dat) создается и постоянно обновляется в каталоге где установлен eMule Plus. В нем содержатся данные:
    - присоединен ли ваш eMule Plus к серверу
    - скорость передачи данных (прием и передача)
    - сервер к которому вы присоединены
    - количество человек стоящих к вам в очереди.
    Одну из программ (не единственную) которая работает с eMule Plus вы можете взять здесь.
    Дополнительную информацию о работе с онлайн-подписью можно получить тут.

    Показывать скорость рядом с кнопками (Show Speed-meter on toolbar)
    Эта настройка включает график скорости передачи данных, отображаемый рядом с кнопками. На нем видно примерное соотношение скоростей приема и передачи данных.

    Записывать сообщения в журнал (Write Log to file)
    Когда разрешена эта настройка в каталоге где установлен eMule Plus создается файл emule.log. В него записываются все сообщения из окна "Журнал". Будьте внимательны - со временем этой файл может разрастись до очень большого размера.

    Лог отладчика (Debug Log)
    Включение вывода программой более расширенной диагностики работы. Эта диагностика помещается в отдельное окно, доступное на странице "Серверы" и так же может быть записан в log-файл. Используйте эту настройку только при наладке программы - создаваемый в этом режиме log-файл может занимать достаточно много места. Обычному пользователя данная функция не интересна.

    Открывать закачки по двойному клику (Doubleclick downloadlist to expand)
    Выбор способа открытия расширенной информации о скачиваемом файле в закладке - одинарным или двойным щелчком мыши.

    Двойной щелчок на клиенте показывает информацию (Doubleclick on client display details)
    При выборе этой настройки двойной щелчек на клиенте показывает информацию об этом клиенте а не открывает чат с ним.

    Показывать имя A4AF файла на каждом источнике (Show A4AF filename on each source)
    Вы можете выбрать что вы хотите видеть: или строку "Запрошен другой файл" или сразу имя этого файла рядом с источником.

    Показывать подсказки через (сек) (Tooltip Delay Time (seconds))
    Вы можете видеть всплывающую подсказку с расширенной информацией когда наводите курсор мыши на файл или источник. Эта настройка указывает сколько секунд должен простоять курсор мыши на выбранном элементе прежде чем всплывет подсказка.

    Приоритет eMulePlus (после перезапуска) (Main Process Priority)
    Назначение приоритета с которым запускается eMulePlus. Назначение высокого приоритета позволяет eMulePlus работать более эффективно но больше загружает центральный процессор вашего компьютера, что может сказываться на работоспособности остальных программ. Для вступления в силу изменений данной настройки необходимо перезапустить eMulePlus. Не желательно устанавливать высокий приоритет, если вы не действительно уверены в том что вы делаете.

    Следующая закладка "Соединение"

    Настройки
    Здесь можно выбрать один из профилей с рекомендованными настройками для новых пользователей. Доступны самые распространённые варианты подключения к Интернет. При выборе профиля, отличного от Custom, рекомендованные настройки не могут быть изменены. В данном случае выбрана типичная ADSL конфигурация: 768kbps/128kbps (kbits per second=килобит в секунду) = 96kBps/16kBps (kilobytes per second=килобайт в секунду). Если вы неуверены в вашем соединении вам стоит спросить об этом у вашего ISP (Internet Service Provider=Провайдер для доступа к интернету)

    Порт клиента
    eMule использует 4662 как заданный по умолчанию порт для загрузки данных от другого клиента. Его изменение необходимо только в случае, если этот порт блокирован, то есть не форвардится на маршрутизаторе или блокирован брендмауером (файерволом) или ISP. В этом случае вы получаете Low ID. Используйте сценарий http://www.thedonkeynetwork.com/connection_test, чтобы проверить, является ли используемый порт открытым для свободного подключения извне, если после получения вы получите в Журнал закладки Сервер сообщение о том что вы получили LowID*.
    *LowID - неприятно, но не смертельно, в данном случае вы сможете пользоваться ресурсами пользователь с HighID, а расшаренные файлы пользователей с таким же LowID вам будут к сожалению не доступны, проще всего попробовать сменить порг на 80 или 1234 например. Если вы в локальной сети коммерческой организации или ВУЗа, то не стоит пытаться получить HighID, если вы лично и близко не знакомы с администратором сети.

    Порт клиента UDP*
    Этот порт отвечает за расширенный протокол eMule, в том числе он используется при обмене источниками между eMule-совместимыми клиентами. Использование UDP между клиентами уменьшает общую загрузку, а также загрузку серверов. Если UDP сбоит, тогда eMule возвращается назад к TCP*.

    *TCP - Transmission Control Protocol
    *UDP - Users Datagram Protocol, упрощённая версия TCP без контроля получения данных, разгружает поток данных

    Порт клиента отключить
    Этой опцией вы можете отключить использование порта UDP. Клиенты будут присоединятся при через TCP, а не UDP.

    Даунлоад (Предел линии)
    Физическая пропускная способность линии на скачивание в килобайтах в секунду. Это значение будет использоваться для масштабирования графиков в окне статистики и во всплывающем меню "быстрые параметры настройки скорости". Оно не затрагивает ограничения на загрузку.

    Апнлоад (Предел линии)
    Физичесая пропускная способность линии на отдачу в килобайтах в секунду. Это значение будет использоваться для масштабирования графиков в окне статистики и во всплывающем меню "быстрые параметры настройки скорости". Оно не затрагивает ограничения на загрузку.

    Даунлоад (Разрешено)
    Ограничение скорости загрузки в килобайтах в секунду. Эта установка должна быть выбрана с умом, так как использование полной скорости канала ухудшит ваш даунлоад/аплоад. Установка ограничения на несколько килобайтов в секунду ниже максимальной пропускной способности канала - оптимальный выбор. Вы не будете качать со скоростью выше выставленных ограничений, даже если позволяет подключение. 0 означает неограниченную загрузку, но не рекомендуется.

    Аплоад (Разрешено)
    Ограничение скорости отдачи в килобайтах в секунду. Эта установка должна быть выбрана с умом, так как использование полной скорости канала ухудшит ваш даунлоад/аплоад. Установка ограничения на несколько килобайтов в секунду ниже максимальной пропускной способности канала - оптимальный выбор. От вас не будут качать со скоростью выше выставленных ограничений, даже если позволяет подключение. 0 означает неограниченную отдачу, но не рекомендуется.

    Размер очереди
    Максимальное количество пользователей в вашей очереди. Маленькое число предпочтительнее, если вы часто закрываете eMule Plus. Большое - если программа работает постоянно. достаточно оставить число предложенное по умолчанию.

    Число соединений
    Максимально дозволенное количество одновременных соединений. Выбор большого числа (вроде 1000) улучшит поиск источников и скорость передачи, но может оборвать связь. Windows 9x/ME не может обрабатывать больше чем 200 одновременных подключений, поэтому превышение этого порога сделает вашу систему склонной к сбоям.

    Число соединений за 5 сек
    Максимально дозволенное количество одновременных соединений в 5-секундном отрезке времени. Установка 20 рекомендуется для Win9x/ME пользователей. Если вас выкидывает сервер попробуйте уменшить ето число до 5.

    Покидать очередь при QR> 2000
    Когда источник дает вам QR больше чем 2000, вы любезно покидаете его очередь, предварительно попрощавшись :)

    Отключить обмен источниками
    Эту опцию следует включить, когда обмен выбранным источниками с пользователями eMule Plus не состоится при установлении соединения. Обмен источниками может принести вам больше источников для ваших файлов, но может оборвать связь. Не рекомендуется отключать ету опцию, если eMule Plus работает должным образом.

    Отключить для файлов с более, чем ... источниками
    После того, как количество источников файла достигает числа внесённого в поле, обмен источниками больше не производится. Желательно не включать, если eMule Плюс работает должным образом.

    Показать оверхед
    Показывать верхнюю полосу пропускания, сгенерированную eMule Plus, в строке состояния и всплывающей подсказке в трее.

    Включить Lancast
    Lancast - особенность, которая позволяет eMule Plus работать лучше в локальных сетях. При включении этой опции eMule Plus посылает широковещательный UDP сигнал в подсеть, а другие eMule Plus со включённым Lancast слушают и принимают эти сигналы, что позволяет скачивать файлы намного быстрее, используя внутренние IP-адреса. После активизации Lancast передачи по сети начнутся в течение нескольких минут или секунд. Lancast не нарушает работу eMule Plus как p2p-приложения, а только дополняет его, продвигая более активное совместное использование файлов и экономию на внешнем траффике в локальных сетях.

    Закладка "Настройки прокси"

    Прокси включен
    Разрешить работу через SOCKS или HTTP 1.1 прокси. Вам также понадобятся дополнительные данные для настройки соединения через прокси. Не забывайте - в случае соединения через прокси вы получаете только LowID. Используйте ету опцию, только если вы уверенны в ваших действиях.

    Тип прокси
    Поддерживается работа через SOCKS 4/4a/5 или HTTP 1.1 прокси. Выберите ваш тип прокси.

    Адрес прокси
    IP-адрес или имя прокси-сервера.

    Порт прокси
    Порт прокси-сервера.

    Логин
    Если ваш прокси требует авторизации, то тут вводится имя для доступа к прокси.

    Пароль
    Пароль для доступа к прокси, если он нужен.

    Аутентификация включена
    Разрешение авторизации если она необходима на вашем прокси. Авторизация поддерживается для Socks5 и HTTP 1.1 типов прокси.

    Закладка "Сервер" (не путать с панэлью "Сервер")

    Попытка соединения с сервером ... сек
    Время на попытку соединения с сервером. Если сервер не отвечает в течении указанного времени, производится попытка присоединиться к следующему серверу в списке.

    Удалять мертвые серверы после ... попыток
    После указанного количества безуспешных попыток соединения с сервером данный сервер удаляется из списка серверов. Эту опцию стоит отключить, если ваш любимый сервер не всегда на УРА вас принимает :)

    Автообновление списка серверов при старте
    Если выбрана эта опция, то при старте eMule Plus пытается обновить список серверов с сайтов, перечисленных в файле adresses.dat. В этом файле возможно перечислять несколько серверов со списками - на случай, если какой-то из них не отвечает. НЕ рекомендуется активизировать эту опцию. Ее применение вызывает большую нагрузку на сайты, содержащие списки серверов. Но можете не беспокоится, без серверов вы не останетесь - встроенный механизм пополнения списка серверов от клиентов и серверов, к которым вы подключены работает замечательно.

    Безопасное соединение с сервером
    Когда выбрана эта опция, eMule Plus пытается соединится только с одним сервером одновременно (вместо двух). Рекомендуем включить эту опцию, чтоб не напрасно не загружать сервера лишним трафиком.

    Умная проверка на LowID при соединении с сервером
    Если вы получили LowID, eMule Plus делает до трех попыток заново соединиться с сервером. После трех попыток функция автоматического соединения отключается. При переборе серверов в попытках соединения используется система приоритетов - сначала пытаемся присоединиться к серверам с высоким приоритетом, затем к серверам с более низким приоритетом.

    Обновить список серверов, когда подключаемся к серверу
    Когда вы присоединяетесь к новому серверу, ваш список серверов сравнивается со списком, имеющимся у этого сервера, и соответственно обновляется. Так же каждый раз, когда к вам присоединяется другой пользователь (или вы присоединяетесь к нему), сервер, к которому присоединен этот пользователь, добавляется в ваш список серверов (если до этого он не был туда занесен). Мы рекомендуем использовать эту опцию вместо того, чтобы добавлять сервера в список вручную или загружать их с сайтов перечисленных в adresses.dat.

    Всегда фильтровать плохие IP
    Сервера, с IP-адресами перечисленными в файле ipfilter.dat, удаляются из вашего списка серверов. Оставьте эту опцию включенной.

    Загружать ожидающие файлы при соединении
    При каждом соединении к серверу eMule Plus будет опрашивать сервер на предмет источников для файлов стоящих в паузе или ожидающих скачивания.

    Автосоединение при старте
    При каждом запуске eMule Plus будет автоматически пытаться присоединиться к серверу. При переборе серверов в попытках соединения используется система приоритетов - сначала пытаемся присоединиться к серверам с высоким приоритетом, затем к серверам с более низким приоритетом.

    Autoconnect to servers in static list only
    При включении этой опции eMule Plus будет пытаться соединяться только с серверами, перечисленными в списке постоянных серверов. Очень хорошая опция :)

    Поддерживать соединение
    При потере соединения с сервером eMule Plus будет пробовать установить соединение с новым сервером. При переборе серверов в попытках соединения используется система приоритетов - сначала пытаемся присоединиться к серверам с высоким приоритетом, затем к серверам с более низким приоритетом. Тоже замечательная опция :)

    Использовать систему приоритетов
    Эта опция разрешает/запрещает использовать систему приоритетов при работе со списком серверов. Просто прекрасная опция :)

    Закладка "Дополнительные"

    Кол-во запросов не более ... (Блокировка)
    Количество запросов которое может сделать один и тот же клиент без указанной паузы между запросами. При достижении этого количества запросов клиент блокируется. Увеличьте кол-во запросов, если большое кол-во пользователей блокируются вашим мулом.

    за ... мин. (Блокировка)
    Количество минут после которого запрос клиента считается своевременным. Оно не может быть больше чем 9.83 минуты (по умолчанию стандартный eDonkey перезапрашивает информацию раз в 10 минут). Уменьшите время, если большое кол-во пользователей блокируются вашим мулом.

    Блокировать на ... мин.(Блокировка)
    Время, на которое блокируется клиент не выполняющий изложенных выше правил. По прошествию этого времени клиент будет разблокирован. Это время не может быть больше чем 300 минут.

    Отправлять сообщение заблокированным клиентам (Блокировка)
    Отправлять сообщение "Вы заблокированы потому что ваш клиент ведет себя слишком агресивно!" каждому блокируемому пользователю, чтобы они знали об этом.

    Активизировать сообщество
    При активизированном сообществе пользователи чье имя содержит указанную вами подстроку получают более высокий приоритет в очереди к вам. Можно указать только одну строку. Учитывается так же маленькие или большие буквы вы используете. При увеличении рейтинга члена сообщества используется модификатор х2 (умножить-рейтинг-на-два), такой же как для Друзей. Очень удобен для создания релиз-групп, при раздаче файлов соуастникам.

    Не блокировать (Сообщество)
    При установке этой опции члены сообщества не блокируются даже если их клиенты ведут себя слишком агрессивно. Имеет смысл если вы создали на базе этих опций обмен файлов с другими участниками релиз-группы.

    Вкл. (Сообщество)
    Включение\выключение работы с сообществом.

    Загружать источники раз в ... мин. (Сохранять\Загружать источники)
    Сохраненные источники будут загружаться каждые ... минут. Указанное значение не может быть меньше чем 60 минут.

    Загружать блоками по ... источников (Сохранять\Загружать источники)
    Источнки будут загружаться блоками по ... источников. Это предотвратит перегрузку вашего канала связи, вызванную слишком большим количеством запросов.

    Не использовать после ... дн. (Сохранять\Загружать источники)
    Источники, к которым вы не смогли присоединиться в течении указанного количества дней будут удалены из списка сохраненных источников. Так же удаляются источники к которым было более трех неудачных попыток соединения.

    Вкл. (Сохранять\Загружать источники)
    Разрешить\Запретить сохранять источники.

    Разрешить подсчет для mlDonkey клиентов
    mlDonkey клиенты ведут себя не совсем справедливо по отношению к eMule (например отдают меньше слотов под соединения с eMule клиентами). При разрешении этой опции eMulePlus при соединении с mlDonkey клиентами идентифицирует себя как eDonkey клиент, для преодоления этой "несправедливости". Классная фишка, держим включенной.

    Закладка "Папки"

    Для скачаных файлов (Incoming Files)
    В этой папке вы найдёте скачаные вами файлы, после успешного завершения скачивания. Содержимое этой папки автоматически расшаривается! Я бы назвал "Входящие" :)

    Для временных файлов (Temporary Files) (Основная папка временных файлов)
    В этой папке находятся части файлов, находящихся в процессе скачивания. Соответствия к загружаемым файлам можно определить наведя курсор мыши на файл в раздле "Передача" (Transfer), после пару секунд появится окошко сообщающее информацию о файле, в том числе и имя временного файла.

    - в данном случае имя временного файла 006.part.

    Установка VideoLAN (Video player for preview)
    Установка VideoLAN-приложения, при помощи которого вы можете делать предосмотр скачиваемого вами фильма. Вы можете так же задать путь к вашему видео-проигрывателю, что НЕ рекомендуется. Этот пункт будет более подробно описан, смотрите через недельку.

    Сделать копию для пред. просмотра (Create backup to preview)
    Для предосмотра программа создаст копию файла, эта опция может помочь, если ваш (другой) плэйер не может проиграть данный видео файл. Етот пункт будет более подробно описан, смотрите через недельку.

    Общие папки (Shared directories)
    Файлы в указанных вами здесь папках будут расшарены, т.е. доступны другим пользователям в качестве русурсов. Удерживая кнопку Ctrl при активировании папки под расшарку, будут так же активированы все папки по иерархии вниз (subfolders).

    Дополнительные Temp папки (Additional Temp directories) (Доп. папка временных файлов)
    Можно использовать ету функцию для выбора дополнительного места на диске под временные файлы, если места в разделе диске (partition) с основной папкой временных файлов не хватает. Не имеет смысла использовать папку в том же разделе диска что и основная папка.

    Закладка "Файлы" (Files)

    Мои файлы видны (See my share)
    Здесь вы можете определить кому из пользователей будет виден список вами расшариваемых файлов. Для жителей стран, в которых блюстители закона "заботятся" о нарушителях авторских прав, категорически рекомендуется установить опцию "Друзья" (Friends) или "Никому" (Nobody)*. Друзьями являются пользователи занесённые вами в список друзей. Запросить файлы другого пользователя можно путём вызова функции "Показать общие файлы"** из popup-меню в разделе "Передача", маркировав предварительно етого пользователя.

    * - не забываейте что вы всё равно остаётесь уязвимы, но так шансы уменьшаются, что за вами подсматривают :)
    ** - довольно неразумное обозначение, стоило бы написать "Показать расшаренные файлы".

    - раздел "Передача" -

    Приоритет хэширования (hashing priority)
    Данная функция позволяет определить насколько хэширование имеет право занимать системные ресурсы вашей системы, в данном случае нагружать процессор (CPU). Если у вас слабый процессор, у вас сравнительно большое кол-во файлов в закачке (10-20-30 и выше) и при старте мула+ вы замечаете зависания - есть смысл понизить приоритет на низкий или незаметный, если ети процессы критически нагружают систему.

    Автоматическая установка приоритета закачки (Upload Autopriority)
    Приоритет будет автоматически увеличиваться или же уменьшаться для думаю всем понятно каких файлов. Участникам релиз-групп рекомендуется отключать эту функцию.

    Размер буфера файла (File Buffer size)
    размер буфера, при наполнении которого информация пишется на диск, желательно не изменять во избежание потери данных и ухудшения работоспособности винчестера (жёсткого диска=HDD), единица измерений в помощи не указана, исходник читать лень ... - предположу что в байтах -> 240 KB значит по умолчанию.

    Максимальное кол-во источников (Max sources per file)
    Кол-во источников допустимое вами с которых будем тянуть, по умолчанию 400 - всегда хватало, жалоб нет.

    Запись завершунного файла блоками по ... кб (Slow completion of files in blocks of ... )
    Помогает расгрузить вашу систему, если папки для временных и скачаных файлов находяться в разных разделах диска и система перенагружается при окончании скачивания.

    Автоустановка приоритетов в аплоаде (Upload Autopriority)
    При активация данной функции будет ставиться автоматически повышенный приоритет на аплоаде файлам, с кол-вом источников менее 40 и пониженный - при более 200. Работает только на скачиваемые файлы!, т.к. на другие мул незнает кол-ва источников. Участникам релиз-групп рекомендуется отключить ету функцию.

    Автоматически удалять ненужные источники (Auto-Remove Unneeded Sources)
    Источники не имеющие нужных вам частей будут автоматически удаляться, если ета опция активирована, таким образом вы не приувеличите макс. кол-во доп. источников, но лишаетесь места в очереди к етому источнику, если он первее вас сзгрузит нужную вам часть. Решение за вами ... :)

    Добавлять закачки ожидающими (Start downloads paused)
    Новодобавленные закачки (downloads) будут автоматически придерживаться в режиме ПАУЗА.
    Оригинальный перевод оглавления фукции ... :)

    Начинать загрузку всех ожидающих после завершения (Start downloading paused file on complete)
    Файлы в режиме ПАУЗА (ожидающие) начнут скачиваться после того как сгружение будет завершено.
    После какого сгружения - о чём идёт речь контекст вспомогательного сайта разработчика умалчивает, методом теста и выжидания пришёл к мнению что какого-либо файла, а не всех. Оглавление переведено правильно, но очевидно что переводчик как и разработчик не удосужились вложить чуток более смысла в эти оглавления :(

    Остальные функции пока не рассматриваются, за отсутствием технического влияния на кач-во работы мула+, да и времени нету на данный момент, позже возможно постараюсь пополнить. Искренне надеюсь помочь коему обывателю в сложных отношениях с новым парнокопытным спутником жизни :)

    При написании были частично использованы материалы netlabа, emuleplus и sharereactora.

    Свои предложения, просьбы и жалобы можно обсудить на форуме ShareReacto.ru, а так же в русскоязычном разделе офиц. форума eMulePlus - убедительная просьба не обращаться по мылу за помощью, именно для етого работает форум более чем с тысячей участников, которые охотно помогут вам разобраться в ваших вопросах.

    Автор: d-face
    Оригинал: www.d-face.de

    Библиотека :: Правильная конвертация DVD в DivX

    1. Введение. Подготовка инстументов.

    Огромное число кривых рипов, появившихся в последнее время, отсутствие полнообъемных русскоязычных материлов по конвертации DVD в DivX и участившиеся вопросы, связанные с конвертацией заставили меня начать писать данную статью. Ее основное назначение - направить новичков в нужное русло, обяснить основные этапы конвертации, дать список необходимых инструментов и конечно же предостеречь от наиболее частых ошибок. Хочется надеятся, что от читателя не потребуется никакаих предварительных знаний в этой области и новички смогут использовать ее как пошаговое руководство.

    Итак, давайте для начала выберем инструменты. Развелось их в последнее время несчетное множество, некоторые даже позволяют получить DivX из DVD-диска буквально двумя щелчками мыши, но это не для нас, наша задача сделать правильный рип, а для этого все же необходимо чтобы процессом руководил человек, нельзя в таком важном деле доверяться машине... В качестве основного рабочего инструмента мы возьмем программу Gordian Knot, которая не просто заслужила доверие лучших специалистов, она разрабатывается при их непосредственном участии. На момент написания статьи вышел GKnot v0.28.5, в котором существует полномерная поддержка кодеков DivX 3.11, XviD, DivX 5.0.5. Стоит отметить, что начиная с версии 0.28 GKnot распространяется по лицензии GPL. Т.е. он абсолютно бесплатен, доступен для скачивания (в том числе и исходными кодами), а его разработкой занимается группа энтузиастов. Нам потребуется скачать и установить следующие пакеты:

    - Gordian Knot Codec Pack - полный пакет кодеков, которые могут понадобиться в процессе кодирования файла в DivX (на момент написания статьи пакет имеет версию 1.4).
    - Gordian Knot Rip Pack - пакет инструментов (включая и саму программу GKnot), которые понадобятся на разных этапах конвертации DVD в DivX.

    В процессе установки пакета кодеков Gordian Knot Codec Pack будут последовательно устанавливаться выбранные вами кодеки. Перед установкой пакета, настоятельно рекомендуется деинсталировать установленные до этого кодеки и фильтры (DivX, XviD, ffdshow и пр.) и установить все кодеки из пакета. Процесс установки может породить кучу вопросов, на которые вам следует отвечать утвердительно.

    При установке Gordian Knot Rip Pack вопросов будет поменьше, но опять же, на все следует дать утвердительный ответ. А вот после установки пакета необходимо совершить некие шаманские действия: запустить программы Nandub и VirtualDubMod (Пуск -> Программы -> Gordian Knot -> Apps) и нажать "Ok" во всех предупредительных окнах, которые могут повиться после запуска.

    Теперь можно запускать программу Gordian Knot (Пуск -> Программы -> Gordian Knot). Сразу после запуска мы увидим рабочее окно программы:

    Сразу идем на закладку Options и приступаем к настройке. Для кодирования мы будем использовать кодек DivX 5.0.5, поэтому первым делом сконфигурим его настройки по умолчанию для первого прохода, N-ного прохода и для кодирования титров. Для этого служат кнопки First Pass, Nth Pass и Credits.

    Сконфигурим для начала первый проход.

    На первой закладке появившегося окна особо много менять не придется. Битрейт выставляется GKnot-ом автоматически для каждого фильма свой. Так что единственное, что мы должны сделать на этой закладке - поставить галку Write MV file, включение которой ускорит следующие проходы.

    Затем переходим на закладку General Parameters. Установка психовизуальной модели (Psychovisual Enhancement) позволяет сэкономить биты для областей, не воспринимаемых человеческим глазом. Рекомендуется устанавливать модель Light для фильмов с высоким битрейтом (2 CD и более) и модель Normal для фильмов с низким битрейтом (1 CD).

    Стоит также убедиться, что в выпадающем списке Perfomance/quality выбран пункт Slowest. Все остальные настройки этой закладке оставляем как есть.

    Теперь переходим к закладке Profiles. Прежде всего здесь необходмо снять галку Choose your profile, после снятия которой, становятся доступными настройки MPEG4 Tools в которых необходио отметить пункты Use GMC и Use Bidirectional Encoding.

    Теперь нажимаем Ok для сохранения настроек в качестве настроек по умолчанию. И нажимаем кнопку Nth Pass для установки настроек по умолчанию для последующих проходов. В аналогичном окне необходимо убедиться, что все настройки совпадают с настройками, сделанными вами для первого прохода. Для титров же рекомендуется использовать поумолчательные значения: режим 1-pass quality based с показателем качества равным 20. Следует отметить, что чем выше цифра показателя качества, тем хуже качество кодирования титров.

    Все те настройки которые мы сейчас сделали будет использоваться для каждого кодирования, которое вы будете делать. Хотя вы конечно всегда можете изменить их перед кодированием очередного фильма.

    Ну все, все настройки сделаны и инструмент готов к работе. Едем дальше...

    2. Этап первый. Декодирование и сброс содержимого DVD на жёсткий диск.

    Как все уже знают (а кто не знает, тот может почитать PC-DVD Faq и узнать), DVD-диски обладают несколькими степенями защиты, встроенными в сам формат. Поэтому обрабатывать информацию прямо с DVD-диска скорее всего не получится. Нам придется декодировать диск и сбросить его содержимое на жесткий диск нашего компьютера (рипнуть диск).

    В принципе, выбор программм для рипования DVD-дисков огромен, у каждой есть свои плюсы и свои минусы, но наиболее стабильные результаты получаются при использовании программы DVDDecrypter. Именно ее я и порекомендую использовать вам. Итак, запускаем GKnot и переходим на закладку Ripping, находим одноименную кнопку DVDDecrypter и жмем ее. Запуститься программа DVD Decrypter.

    Удостоверимся, что программа работает в режиме IFO, для этого проверим, что в меню Mode выделен пункт IFO. Программа самостоятельно авторизует диск и определит файлы которые необходимо рипать (надеюсь вы в курсе, что на диске кроме самого фильма находятся еще и дополнительные данные, такие как рекламные ролики, меню и пр., их рипать нужды нет). Таким образом на панели Input окажется выделенным PGC (Programm Chain) длина котого, должна совпасть с продолжительностью фильма.

    Не откладывая на потом, сразу же определимся с потоками, для этого перейдем на закладку Stream Processing. Здесь мы видим список потоков, среди которых есть видео потоки, потоки субтитров и аудипотоки для разных языков. Нас интерисуют прежде всего аудиопотоки. Каждый поток имеет идентификатор, при этом 0х80 соответствует потоку №1, 0х81 потоку №2 и т.д. Выберите необходимую звуковую дорожку и запомните (а лучше даже запишите) ее номер, он понадобится нам позже.

    Теперь выберем каталог для сохранения файлов, для этого нажмем кнопку со значком папки в разделе Destination и выберем каталог.

    Вот собственно и все, все необходимые подготовительные действия для этого этапа совершены, можно запускать процесс рипанья, для этого жмем большую кнопку Decrypt и ждем завершения процесса.

    Процесс рипанья может занять до 40 минут, это зависит от скорости вашего DVD-привода и жесткого диска, а так же от количества VOB-файлов. После того, как содержимое DVD диска расшифровано и лежит на жёстком диске, самое время приступать к собственно перегонке фильма в DivX.

    3. Этап второй. Создание d2v-проекта, вырезание звука.

    На этом этапе нашим инструментом станет программа DVD2AVI, входящая, как и DVDDecrypter, в состав пакета Gordian Knot Rip Pack. Запустить DVD2AVI можно с закладки Ripping программы GKnot нажатием одноименной кнопки.

    Сразу после запуска необходимо открыть рипнутые VOB-файлы, для этого используем меню File -> Open или кнопку F3 и выбираем нужные файлы. В принципе, программе достаточно указать только первый VOB, остальные будут загружены автоматически.

    Следующим нашим шагом будет определение типа фильма, с которым мы имеем дело. Прежде всего, зайдите в меню Video и установите Field Operation в None. Затем запускаем предварительный просмотр из меню Option -> Preview или нажатием кнопки F5. По прошествии нескольких минут останавливаем предварительный просмотр нажатием кнопки Esc и обращаем свое внимание на повившееся справа окно Information.

    Здесь есть два важных параметра которые необходимо запомнить (а лучше записать). Первый параметр это Aspect Ratio, он может иметь значения 16:9 или 4:3. Второй важный параметр это Frame Type, он может быть Progressive или Interlaced. Хотя DVD2AVI порой ошибается в этом параметре, но опытному глазу интерлейсиный материал видно сразу. Значения этих параметров для нашего фильма понадобятся нам в дальнейшем.

    Теперь обратим свой взор на параметр Frame Rate.

    Если Frame Rate = 25.000 fps, то мы имеем дело с PAL-овским исходным материалом. Если при этом Frame Type имеет значение Interlaced, то запустите предварительный просмотр снова (F5), и хорошенько присмотритесь к изображению, на предмет наличая черных горизонтальных линий. Если линий нет, значит DVD2AVI ошиблась в опредлении Frame Type, исходный материал на самом деле Progressive, и мы можем переходить к следующему шагу. Если же полосы имеют место быть, попробуйте выбрать пункт Swap Field Order в меню Video -> Field Operation и повторно запустить предварительный просмотр (F5). Если после включения Swap Field Order черные линии пропали - перходим к следующему шагу, если же избавиться от них не удалось - сбрасываем Video -> Field Operation назад в None.

    Если Frame Rate = 20.000 fps, то мы опять же имеем дело с PAL-овским исходным материалом, но в меню Video -> Field Operation у вас выбран пункт Forced Film (хотя я вам говорил сбросить его в None!). Для получения корректного результата вам необходимо выбрать пункт None в меню Video -> Field Operation.

    Если Frame Rate = 29.970 fps, запускаем предварительный просмотр (F5) на пару минут еще раз и смотрим на параметр Video Type, если он имеет значение FILM с процентным числом более или равным 95%, необходимо активизировать функцию Forced FILM в меню Video -> Field Operation. Иначе вам необходимо будет в дальнейшем выполнить операцию обратного преобразования IVTC, процесс выполнения которой будет описан ниже (помечаем себе необходимость ее выполнения, чтоб не забыть).

    Значение Frame Rate = 23.976 fps сведетельствует о том, что активизирована функци Forced FILM для исходного NTSC материала. Если при этом Video Type имеет значение FILM или FILM с процентным числом больше или равным 95% оставяем все как есть и переходим к следующему шагу. Если же процентное число ниже или Video Type имеет значение NTSC, то вам необходимо выбрать в меню Video -> Field Operation пункт None и произвести в дальнейшем операцию обратного преобразования IVTC, пометьте себе это чтобы не забыть (объяснения о том как это делается будут даны ниже, когда настанет время для этого).

    И наконец, чтобы закончить с установкий параметров видео, проверим, что в меню Video -> Color Space выбран пункт YUV 4:2:2, т.к. видеоданные должны остаться в этом формате для обеспечения их быстрой и безошибочной обработки.

    Следующим нашим шагом станет установка необходимых параметров для получения звука из VOB-файлов. Замечу сразу, что в интернет-сообществе до сих пор не сложилось четких рекомендаций по этим настройкам: одни руководства советуют не менять настройки по умолчанию, другие наоборот советуют. Лично я склонен верить последним, поскольку в их создании принимали участие специалисты, заслуживающие доверия. Именно их рекомендации я изложу вам далее.

    Итак, приступаем к настройке параметров вырезания звука. Первым делом в меню Audio -> Track Number выберем номер звуковой дорожки, которую мы хотим получить из VOB-файлов и которую, собственно, будет содержать наш фильм. Как вы помните, на первом этапе, во время рипанья DVD-диска, мы заглянули в раздел потоков и определили по названию номер нужной нам звуковой дорожки. Если же вы что-то пропустили, и не знаете какая дорожка вам нужна - загляните в файл "VTS_0х - Stream Information.txt", который лежит в том же каталоге, что и VOB-файлы и выберите по названию и формату необходимую дорожку, имея ввиду, что 0x80 соответсвует дорожке №1, 0x81 дорожке №2 и т.д.

    Затем, проверям, что в меню Audio -> Dolby Digital Decode -> Dynamic Range Control установлен режим Nornal. А в меню Audio -> 48 -> 44.1KHz выбан пункт Off. Теперь выбираем пункт Audio -> Normalization и в появившемся окне устанвливаем флажек, расположенный в правом верхнем углу и устанавливаем рычажек Volume в значение 80.

    Теперь необходимо определиться, какой звук мы хотим получить: стерео или AC3. Для стерео звука необходимо выбрать пункт Decode to WAV (AC3, LPCM) в меню Audio -> Output Method. Или пункт Demux (AC3, MPA, DTS) в том же меню Audio -> Output Method для получения звука в формате AC3.

    На этом установка всех параметров закончена и можно сохранять наш d2v-проект, вырезая попутно звуковую дорожку. Для этого выбираем пункт меню File -> Save Project (или просто нажимаем F4) и указываем имя d2v-файла.

    После сохранения проекта, мы получим d2v-файл и файл звуковой дорожки в формате wav или ac3 в зависимости от выбранных настроек. Но только не удаляйте vob-файлы, они еще будут нужны. И вообще, рекомендую не стирать их до тех пор пока DivX фильм не будет полностью готов.

    4. Этап третий. Обработка звуковой дорожки.

    Относительно третьего этапа существуют два мнения. Первое сводится к тому, что сразу после создания d2v-проекта необходимо переходить к выбору параметров кодирования видео, поскольку в этом случае можно "поиграться" с различными параметрами и выбрать оптимальные настройки кодирования звуковой дорожки, так чтобы объем звука не забирал драгоценные мегабайты у видео. Но так как заранее достаточно точно предугадать объем звуковой дорожки, зная параметры кодирования невозможно, потеря этих самых мегабайт все равно неминуема.

    Второй подход говорит, что после создания d2v-проекта необходимо сжать звук и лишь затем переходить к обработке видео. Лично я склоняюсь ко второму подходу, поскольку фильмы смотрю не на той аппаратуре, где можно отличить средненький звук от великолепного, и параметры, при которых звук не будет казаться мне ужасным, занимая при этом минимальный объем известны мне заранее. Плюс ко всему этот поход позволяет позволяет достичь более точных результатов в получении файла заданного объема. Воспользуемся и мы вторым подходом и перейдем к кодированию звуковой дорожки.

    Обработка стерео-звука

    Итак, если при создании d2v-проекта, мы выбрали опцию декодирования звуковой дорожки в WAV-файл, то в том же каталоге, где сохранен наш d2v-файл должен был появитсья и wav-файл, содержащий звук. Имя этого файла достаточно длинное, что-то типа "kp AC3 T01 3_2ch 448Kbps 48KHz.wav". В самом имени файла DVD2AVI вписала все его основные параметры.

    Теперь нашей основной задачей станет конвертирование этого wav-файла в формат mp3. Для этого воспользуемся программой Lame, последнюю версию которой необходимо скачать и распаковать. В стандартный комплект этого кодировщика не входит никакой графической оболочки, поэтому вам придется использовать Lame в режиме командной строки или скачать одну из графических оболочек для lame-а, например RazorLame, которую так же необходимо развернуть из архива.

    Итак, запускаем RazorLame и добавляем в список наш wav-файл, содержащий звуковую дорожку путем нажатия кнопки Add на панели инструментов и указываем местоположение нашего файла.

    После добавления звукового файла, жмем кнопку LAME на панели инструментов, для задания параметров кодирования звука. После нажатия кнопки открывается окно LAME Options в котором сразу переходим на закладку Expert. Отмечаем флажек Only use custom options. А в строке Custom options вводим следующее "--abr 96 -h --nspsytune --athtype 2 --lowpass 16 --ns-bass -8 --resample 44.1".

    В принципе тут всего один параметр для варьирования - поток данных, мы выбрали его равным 96 kbit/s, некоторые выбирают его равным 112 или даже 128 kbit/s. Лично меня поток в 96 kbit/s вполне устраивает, минимум объема при качестве, неотличимом на моей аппаратуре от 112 kbit/s. В некоторых случаях, правда, можно сделать и 64 kbit/s, когда важен каждый килобайт, съэкономленный на звуке в пользу видео. Резюмируя, не опускайте битрейт ниже 64, и не поднимайте выше 128, среднестатистически старясь держаться цифры 96 kbit/s. Допустимые значения для битрейта: 64, 80, 96, 112 и 128 kbit/s.

    Отмечу так же, что параметром "--resample 44.1" мы ресэмплируем звук на 44.1 kHz. Оригинальная частота дикретизации прописана, кстати, в названии файла, например файл "kp AC3 T01 3_2ch 448Kbps 48KHz.wav" - частота дискретизации 48 kHz. Так вот, некоторые товарищи поговаривают, что в некоторых случаях при ресэмплировании можно получить рассинхронизацию звука и видео и рекомендуют оставлять оригинальную частоту дискретизации, но лично я никогда не сталкивался с подобной проблемой и всегда произвожу ресэмплировние, которое позволяет достичь более высокое качество звука при том же объеме данных.

    Над остальными параметрами можете не задумываться, их набор выработан в результате долгих опытов многих людей и является в большинстве случаев оптимальным для кодирования звуковых дорожек фильмов.

    Итак, после указания параметров кодирования звуковой дорожки жмем Ok для подтверждения введенных параметров и закрытия окна настроек. И нажимаем кнопку Encode на панели инструментов для начала кодирования. Если это первый запуск процесса кодирования, RazorLame попросит вас указать местоположение программы lame.

    После завершения процесса кодирования, в том же каталоге, где расположен исходный wav-файл, появится mp3-файл имеющий имя, аналогичное исходному файлу. На этом третий этап завешен и можно переходить к следующему этапу.

    Обработка AC3-звука

    Если при создании d2v-проекта, вы решили что вам необходим ac3-звук и выбрали опцию Demux, то в том же каталоге, где располагается d2v-файл появится файл с раширением .ac3. В имени файла, кроме выбранного вами названия проекта будет содержаться базования информация о файле, например "kp AC3 T01 3_2ch 448Kbps DELAY 333ms.ac3". Как уже упоминалось, в самом названии файла содержится информация о битрейте, в приведеном выше примере битрейт равен 448 kbit/s, что на мой взгяд является излишеством, передировав звуковую и дорожку с пониженным битрейтом, мы сможем выиграть дополнительное место для видео.

    К сожалению, программа обработки ac3-звука BeSweet, входящая в комплект в Gordian Knot Rip Pack, при перекодировании звуковой дорожки с уменьшением битрейта, дает значительное уменьшение громкости, и поэтому нам не подойдет. Лично я рекомендую использовать вам программу Sonic Foundry Soft Encode, к единственственному недостатку которой можно отнести ее небесплатность. Но, будем считать, вы тем или иным способом приодолели ее главный недостаток и у вас установлена рабочая версия этой программы.

    Итак, запускаем Soft Encode и открываем наш ac3-файл, содержащий звуковой дорожку при помощи меню File -> Open. Процесс открытия ac3-звука достаточно продолжителен по времени и после его завершения в рабочем окне программы мы увидим графическое представление звука для каждого из 6 его каналов.

    После открытия исходного файла, в меню Options выбираем пункт Encode Settings..., что вызовет появление на экране одноименного окна. В этом окне, единственный параметр который нам предстоит изменить, это Data rate, остальные же параметры я рекомендую вам не трогать и оставить все значения как есть. При выборе битрейта рекомендую вам не опускаться ниже цифры 320 (иначе будет заметно ухедшение качества) и не подниматься к цифре 448 kbit/s (а то зачем мы вообще затеваем перекодирование, ведь битрейт 448 kbit/s иммет оригинал). Так что выбор, собственно, состоит всего из двух вариантов 320 или 384 kbit/s, мое ухо, например, на моей аппаратуре слабо улавливает разницу между этими величинами, поэтому я обычно выбираю 320 kbit/s, экономя при этом место для видео.

    После установки параметров кодирования звука, начинаем собственно перекодирование выбрав в меню File пункт Save As..., указав имя файла и утвердительно ответив на вопрос программы о том, что перекодировка файла повлияет на него и хотим ли начать процесс перекодирования. Сам процесс потребует достаточно много времени и после его завершения, мы будем иметь ac3-файл с пониженным битрейтом и, как следствие, имеющий меньший размер. Теперь можно переходить к следующему этапу.

    5. Этап четвертый. Предварительная настройка параметров видео.

    Запускаем Gordian Knot, и сразу обращаем внимание в правый нижний угол, в раздел Save. Здесь содержится список из 8 точек сохранения, которые позволяют запоминать выбранные настройки, дабы в дальнейшем можно было вернуться к параметрам, выбранным для какого-либо фильма. Выбираем в выпадающем списке свободную точку сохранения и нажатием кнопки Rename переименовываем ее так, чтобы было понятно к какому фильму она относится.

    Затем открываем наш d2v-проект, путем нажатия кнопки Open в левом нижнем углу и выбора нужного файла.

    После открытия проекта, в соседнем разделе Frames будет автоматически выставлено соответствующее число кадров фильма и его fps (кадров в секунду). Если FPS = 29.970 и у вас помечено, что необходимо сделать обратное преобразование IVTC, то установите в выпадающем списке значение fps равное 23.976 (при этом количество кадров в строке ввода выше будет автоматически пересчитано). Если в выпадающем списке FPS пусто, значит вы накосячили с созданием d2v-проекта и вам необходимо вернуться ко второму этапу и проделать все повторно, но уже более внимательно. Во всех остальных случаях (FPS=25.00 или fps=23.976) можно продолжать двигаться дальше.

    Также, после открытия проекта, появится окно с изображением одного из кадров фильма, уберите это окно на задний план, но не закрывайте его.

    Теперь переходим на закладку Bitrate и начинаем проверку и установку параметров, связанных с вычислением битрейта фильма. Перво-наперво убедимся, что в разделе Mode выбран пункт Calculate Average Bitrate, этот режим позволяет высчитывать битрейт фильма для получения заданного объема.

    Затем, в разделе Codec выбираем кодек, который мы будем использовать для сжатия. Рекомендую, нет даже настоятельно советую вам использовать кодек DivX 5. Именно на его примере будет построено дальнейшее повествование.

    Теперь переходим к выбору желаемого объема для фильма. Прежде всего в разделе Total Size выбираем из выпадающего списка размер болванки. Если это не особый случай, то естественно 700 Мб. Затем жмем на кнопку, соответствующую количеству дисков для нашего фильма, обычно 1 или 2 CD. И в случае нескольких CD отмечаем флажек Split final file into CDs для автоматической разбивки файла по дискам после окончания процесса кодирования.

    В разделе(ах) Audio мы указываем файл(ы) звуковых дорожек, которые будет содержать наш фильм. Так, в разделе Audio A, жмем кнопку Select и выбираем подготовленный нами ранее звуковой файл. При этом, автоматически выделится пункт Size, а в строках ввода KB и MB оборазится размер нашего звукового файла в килобайтах и мегабайтах соответственно. Так как наш файл будет содержать лишь одну звуковую дорожку, в разделе Audio B должен быть выбран пункт Size с размером 0.

    В связи с тем, что в файле, содержащем аудио и видео данные, необходимо отвести место, для хранения информации о синхронизации аудио и видео данных, мы должны указать тип звуковой дорожки, для корректного учета объема, необходимого для хранения информации о синхронизации. Для этого, в разделе Interleaving & AVI-Overhead выберем пункт, соотвествующий количеству звуковых дорожек файла и их типу. Для одной mp3-дорожки: 1x vbr-mp3, для одной ac3-дорожки: 1x ac3/cbr mp3. Следует так же отметить, что в случае ac3-звука мы имеем возможность задать количество кадров, через которое необходимо синхронизировать звук и видео, увеличение этого числа уменьшает объем информации о синхронизации, но не стоит выставлять его больше 3-4 кадров, поскольку это может привести заикающемуся звуку, либо к дёрганому изображению. Не забываем, здесь, так же поставить флажек Calculate Frame-Overhead.

    Вот теперь все параметры, влияющие на битрейт выставлены, и в разделе Video мы можем наблюдать значение битрейта для видеопотока. Замечу, что теперь повлиять на битрейт мы сможем лишь либо уменьшением размера файла звуковой дорожки перекодировав ее с меньшим битрейтом, либо увеличением числа дисков, занимаемых фильмов.

    Далее, переходим на закладку Resolution. Здесь сразу обращаемся к разделам Input Resolution и Input Pixel Aspect Ratio. Первый раздел позволяет указать ТВ-систему (PAL или NTSC), этот параметр был выявлен нами на этапе создания d2v-проекта (если вы забыли и не записали, обратитесь к текстовому файлу Stream Information.txt, созданному на том же этапе, там прописана ТВ система для видеопотока). В разделе Input Pixel Aspect Ratio выбираем соотношение сторон, также выданное нам программой DVD2AVI (16:9 или 4:3).

    И переходим к более деликатному делу - обрезанию черных полос на избражении. Первую итерацию этой процедуры возложим на компьютер, для чего в разделе Crop (before resize!) нажмем кнопку Auto Crop и подождем пока в окне предварительного просмотра GKnot пролистает несколько кадров видео. После завершения процедуры автоматического определения границ изображения, будет автоматически выбран режим Pixel в том же разделе и поля ввода справа заполнятся цифрами, соответсвующими размерам обрезания слева, сверху, справа и снизу соотвественно расположению. Теперь стоит проверить насколько хорошо компьютер справился с этой задачей, для этого переходим в окно предварительного просмотра и внимательно смотрим на края изображения, на разных кадрах, желательно наиболее светлых. Если где-то остались черные полоски, или неровные границы кадра - обрезаем их при помощи стрелок около строк ввода размеров обрезания. Режем беспощадно, добиваясь четкого прямоугольного кадра, потому что пикселем больше, пикселем меньше - роли не играет, а вот кривой кадр будет потом бросаться в глаза, да и сжиматься будет хуже. После того, как кадр идеально вырезан, выбираем в разделе пункт Smart Crop All, после чего изображения будет еще немного подрезано, для получения правильной пропорции отношения высоты к ширине.

    Теперь самое время проверить результаты нашего труда, для этого переключаемся в окно предварительного просмотра и в меню View отмечаем пункт Resized. Мы должны увидеть идеально обрезанный кадр, без черных полос с боков и неровных границ (если это не так вы плохо сделали обрезание кадра), и самое главное лица должны выглядеть естественно, т.е. не быть сплюснутыми или вытянутыми (если что-то не так значит вы неправильно установили Input Resolution или Input Pixel Aspect Ratio).

    Теперь переходим к одному из важнейших шагов - предварительному выбору размера фильма. Почему важнейшему? Дело в том что для каждого фильма (а точнее для конкретной степени сжимаемости фильма) и для каждого битрейта существует только одно оптимальное значение размеров. И не думайте, что чем больше размеры, тем лучше качество картинки. Оптимальные размеры разные для каждого фильма и для каждого битрейта. Если выбрать размеры слишком большие, то на экране будет много "квадратов", если же выбрать слишком малые, то мы просто подойдем к порогу сжатия и те же самые результаты могли бы быть получены для картинки большего размера, так мы впустую потратим место на болванке. Так что размер должен быть выбран оптимально! Почему предварительному? Да потому что мы еще пока не знаем степени сжимаемости фильма в данном разрешении. И вполне возможно, что фильм сжимается плохо и его размеры придется взять поменьше, а может быть наоборот, сжимается хорошо и можно выбрать размеры побольше. Степень сжимаемости, кстати, зависит от целого ряда параметров, среди которых повторяемость участков изображения от кадра к кадру, количество пикселей, изменяющих свой цвет на следующем кадре, количество и размеры областей, состоящих из пикселей, цвет которых неотличим человеческим глазом друг от друга и многих других. Но вот узнать степень сжимаемости не производя кодирование невозможно. Т.е. узнать степень сжимаемости можно только закодировав фильм. А чтобы закодировать фильм нужно выбрать его размеры исходя из степени сжимаемости. Вот такой замкнутый круг...

    Но хватит философии, вернемся к практике. Итак нам необходимо выбрать размеры для нашего фильма. Причем воспроизведение видео на компьютере тоже накладывает свои ограничения - для того чтобы фильм проигрывался без рывков необходимо, чтобы его ширина была кратна 32, а высота кратна 16. Это в идеале. В принципе нет ничего криминального и в кратности ширины 16, но гарантий корректного вопроизведения такого фильма на всех видеокартах и на всех драйверах уже не будет, хотя чаще всего и будет работать.

    Обращаем внимание в нижнюю часть закладки Resolution. Здесь мы видим раздел Output Resolution, содержащий информации о размере видео (Width x Height), кратности ширины и высоты (W-Modul и H-Modul) при выборе размеров, процент ошибки отношения высоты к ширине в получаемом файле (Aspect Error, обычно ниже 2%), а так же еще ряд параметров, которые не представляют для нас особого интереса.

    Ниже расположен бегунок, при помощи которого можно изменять размеры видео в соотвествии с заданной кратностью ширины и высоты (рекомендую вам не менять кратности). При перемещении бегунка, изменяется конечное разрешение, отображаемое в разделе Output Resolution. И, паралельно, пересчитывается параметр Bits/(Pixel*Frame), отображаемый в одноименном разделе.

    Именно параметр Bits/(Pixel*Frame) будет нашей предварительной оценочной характеристикой качества изображения. Как я уже говорил, не зная степени сжимаемости, нельзя выбрать оптимальное разрешение, но эмпирически получены следующие постулаты:

    - Не опускайте высоту изображения ниже планки в 256 пикселей и не заползайте за цифру 400;
    - Опускать Bits/(Pixel*Frame) ниже 0.17 не стоит;
    - При кодировании фильма на 1CD придерживайтесь значения Bits/(Pixel*Frame) в районе 0.20;
    - При кодировании фильма на 2CD придерживайтесь значения Bits/(Pixel*Frame) в районе 0.27;
    - Если Bits/(Pixel*Frame) не удается поднять выше 0.15 при разумных значениях высоты - увеличьте битрейта путем увеличения количества дисков или за счет уменьшения объема звуковой дорожки;

    Не следует забывать так же, что при воспроизведении на экране ТВ, фильм с размером 288 по вертикали, но без "квадратов" вызванными пониженным Bits/(Pixel*Frame) смотрится лучше чем тот же фильм с 384 строками и с пониженным Bits/(Pixel*Frame), в следствии неидеальности самого телевизора. Но не перборщите, а то можете перешагнуть за предел сжимаемости.

    И, главное, помните - наш выбор лишь предварителен, мы еще не знаем истиного значения степени сжимаемости фильма. Может случиться так, что фильм с Bits/(Pixel*Frame) = 0.28 будет выглядеть ужасно, а может быть и при значении 0.17 будет выглядеть великолепно.

    Закончив с первоначальным выбором разрешения, переходим к окну предварительного просмотра. Здесь, при помощи ползунка, нам необходимо установить момент начала титров. Т.е. момент, когда кино закончилось, а титры еще не начались. Обычно появлению титров предшествует кадр с черным экраном, именно на этот момент необходимо и установить ползунок. Хотя конечно черного экрана можети не быть, тогда необходимо просто поймать момент их начала. Установив ползунок в нужном месте, нажимаем кнопку Set Credits Start. Нужно это, как вы наверное поняли из предыдущего повествования, для того чтобы кодировать титры (на которые обычно мало кто обращает особое внимание) с пониженным битрейтом, экономя места для самого фильма.

    Установив момент начала титров, вызываем пункт Save & Encode из меню File окна предварительного просмотра. На экране появится окно "Save .avs".

    Здесь нам предстоит установить ряд параметров, первый из них - Resize Filter, который задает режим сглаживания при масштабировании видеоизображения. По идее, GKnot сам предложит оптимальный режим исходя из битрейта, но лучше выбирать его исходя из своего опыта и самого видеоизображения. Режим билинейной фильтрации (Bilinear) уменьшает четкость изображения, слегка сглаживая переходы, но повышает степень компрессии изображения, а так же обладает более высокой скоростью работы. Бикубические режимы (Soft Bicubic, Neutral Bicubic, Sharp Bicubic) обладают более высокой передаваемой честкостью, но как следствие менее сглаживают шумы, ухудшают степень сжимаемости и увеличивают время кодирования. Режим фильтрации Simple дает неважный результат, но обладает высокой скоростью работы. Режим Lanczos стоит выбирать лишь для очень низких битрейтов. Для начала посоветую вам билинейный или бикубический нетральный режимы.

    Следующим шагом будет деинтерлейсинг, если конечно он необходим (на предыдущих шагах я говорил вам сделать отметку о необходимости его выполнения). Если в деинтерлейсинге нет необходимости, выбираем в разделе Field Operations пункт None. Если же необходимо выполнить интерлейсинг, и устранить его на этапе создания d2v-проекта, путем установки режима Swap Field Order не удалось, значит метод Separate Fields нам не подойдет (он аналогичен режиму Swap Field Order), метод Field Deinterlace в некоторых случаях может давать "тень" на быстродвижущихся объектах, следовательно выбор сводится к методам Field Deinterlace (no blend), Smart Bob и TomsMoComp. На сегодняшний день сообщество еще не пришло к единому мнению какой из них лучше, и на мой взгляд они дают практически одинаковый результат. Рекомендую вам в случае необходимости деинтерлейсинга использовать метод Field Deinterlace (no blend).

    И последний параметр который необходимо выбрать - фильтр шумов. Фильтр бывает полезен в случае, если источник обладает достаточно сильным уровнем видео-шумов, и вредным в случае источника с "чистой" картинкой, поскольку наложение фильтра влечет за собой ощутимые искажение цветовых переходов. Следует так же отметить, что использование фильтра шумов резко увиличивает сжимаемость фильма. Если вы не хотите использовать фильтр - выбирайте в разделе Noise Filter пункт None. Если же источник достаточно шумный выбирайте пункт Little Noise. Использовать фильтр Medium Noise рекомендуется только в случаях чрезвычайно шумного источника, а использовать Heavy Noise вообще не рекомендуется из-за черезвычайно высоких искажений, получаемых при его использовании.

    И, наконец, выбираем в разделе Trim пункт Both (enc. credits separately), для указания необходимости кодирования самого фильма и титров с разным качеством. Но кнопку Ok пока не нажимаем, а переходим к следующему этапу.

    6. Этап пятый. Тест сжимаемости.

    Как уже говорилось ранее, каждый видеоматериал обладает неким коэффициентом сжимаемости, который показывает насколько хорошо может быть этот материал сжат при помощи алгоритма MPEG-4. Но единственный способ получить этот коэффициент - провести тестовое сжатие, что потребует достаточно много времени. Поэтому, для оценки степени сжимаемости фильма, проводят кодирование не всего фильма целиком, а лишь отдельных его частей (обычно 5%).

    Для проведения теста сжимаемости отмечаем пункт Use в разделе Compressibility Check и запусаем процесс нажатием кнопки Now. После утвердительного ответа на вопрос, действительно ли мы хотим провести тест сжимаемости, начнется тестовое кодирование части исходного материала, при этом на экране появится окно, отображающее ход выполнения процесса.

    По окночании процесса, все окна отображаюшие ход процесса будут автоматически закрыты, а в заголовке окна предварительного просмотра появится надпись "Compressibility Check: Finish". Обратим теперь свое внимание на раздел Bits/(Pixel*Frame), который находится в нижней части главного окна GKnot. Ориентируясь именно на цифру этого раздела мы предварительно выбирали размер видео. После же проведения теста сжимаемости, в этом разделе появятся 2 новые цифры: приблизительный коэффициент, показывающий насколько хорошо может быть сжат данный фильм (3-ий столбец) и выраженное в процентах отношение между оптимальным и выбранным Bits/(Pixel*Frame).

    В данном примере разрешение выбрано таким, что Bits/(Pixel*Frame) равен 0.362, а тест сжимаемости показал что оптимальным будет значение 0.446, при этом выбранное значение составляет 81.1% от оптимального.

    Теперь необходимо скорректировать разрешение с учетом результатов теста сжимаемости. Если выбранное значение совпадает с оптимальным, т.е. процентное соотношение равно 100%, то выбрано самое оптимальное разрешение, и вы получите идеальное изображение. Если соотношение составляет более 100% это перебор, вы не получите значительного улучшения качества изображения, использовав в пустую отведенный для фильма размер файла, в этом случае необходимо увеличить разрешение. Процентное соотношение в интервале 80-100% дает очень хороший результат, интервал 60-80% говорит о том, что качество будет нормальным, значения в интервале 40-60% так же являются приемлемыми для некоторых фильмов, опускаться же ниже 40% крайне не рекомендуется, это уже будет отвратительное качество.

    Как уже упоминалась выше, на степень сжимаемости влияют такие параметры как метод фильтрации при масшатабировании и фильтр шумов, но для того чтобы узнать насколько изменится степень сжимаемости при изменении этих параметров необходимо повторно проводить тест сжимаемости, меняя необходимые параметры.

    7. Этап шестой. Кодирование.

    Итак, разрешение для фильма выбрано, можно приступать к собственно кодированию. Опять вызываем окно "Save .avs" из меню File -> Save & Encode окна предварительного просмотра. Удостоверяемся что все параметры выбраны так же, как при проведении теста сжимаемости, и в разделе Trim выбираем пункт Both (enc. credits separately) указывая, что титры нужно кодировать отдельно от фильма с другим качеством и добавлять к фильму после окончания кодирования.

    Теперь нажимаем кнопку Save & Encode и в появившемся диалоговом окне указываем месторасположение и название файла фреймсервера (служебного файла, необходимого в процессе кодирования) для основного фильма и для титров.

    После этого, появится диалоговое окно DivX Encoding Control Panel, в котором необходимо настроить параметры для автоматического кодирования видео и наложения звуковой дорожки.

    Первым делом удостоверимся, что выбран режим многопроходного кодирования, в правом верхнем блоке переключателеей должен быть выбран пункт Multi Passes. Затем перейдем к закладке Audio 1

    Проверим, что в строке Audio Source File выбран файл с нашей звуковой дорожкой. В разделе переключателей выберем пункт Just Mux, указывая, что обрабатывать звук не надо, а после кодирования необходимо просто наложить его. Теперь обратим внимание на раздел Delay, здесь выставляется задержка аудиопотока отностительно потока видео. Если при создании d2v-проекта был выбран режим Decode to WAV, то время задержки было автоматичеки учтено при создании wav-файла и следовательно необходимо установить параметр Delay в ноль. Если же в программе DVD2AVI для получения звука использовался режим Demux, то задержку необходимо учитывать. Выяснить величину задержки можно либо заглянув в файл "VTS_0х - Stream Information.txt", который DVDDecrypter заботливо разместил в том же каталоге, что и vob-файлы. Либо просто отбратиться к назанию файла, например для файла "ssch AC3 T01 3_2ch 192Kbps DELAY 197032ms.ac3" задержка, как явствует из его названия составляет 197032ms. Если задержка представляет собой отрицательное число, то необходимо указать задержку без знака минуса и отметить пункт negative. В разделе Interleaving оставляем все значения по умолчанию и переходим к закладке DivX 5.

    Очередной раз проверим правильность настроек кодека для первого и последующих проходов, а так же настройки для кодирования титров, нажимая соотвествующие кнопки "First Pass", "Nth Pass" и "Credits". Сделать это надо обязательно, поскольку GKnot контролирует нажатия этих кнопок и не даст возможности продолжить без просмотра настроек.

    Теперь следует определиться с количеством проходов кодирования (Number of passes). Кодек DivX позволяет производить кодирование в несколько проходов и в теории, каждый следующий проход должен давать лучший результат. Но в связи с тем, что каждый проход занимает достаточно длительное время и разница становится неощутима на глаз уже после нескольких проходов, имеет смысл ограничить это число 3-4 проходами.

    Активизируем функцию пересчета битрейта при несовпадении размера файла, отметив флажек "Re-Calculate Bitrate if needed". Включим опцию кодирования титров с пониженным качеством "Encode Credits at avarage quant" и так же, при желании, изменим сам коэффициент качества. Включим функции добавления титров после завершения кодирования "Append Credits (needs 2 x HD-Space)" и функцию удаления файлов промежуточных проходов "Delete Intermeadiate Files (1/2 HD-Space)".

    Наимаем кнопку "Add Job to Encoding Queue" для добавления задания в очередь кодировния и положительно отвечаем на вопрос о том, хотим ли мы приступить к кодированию прямо сейчас.

    GKnot автоматически переключится на закладку Encoder, в верхней части которой, будут видны задания кодирования, а в нижней будут повляться комментарии к ходу выполнения. Вот теперь остается лишь ждать завершения кодирования, после окончания которого будет получен готовый avi-файл.

    Автор: mawr

    Библиотека :: Использование кодека On2 VP6.

    Не секрет, что самый популярный на сегодняшний день видео кодек DivX морально устарел и на свет уже давно появились кодеки нового поколения, способные делать DVD рипы с заметно лучшим качеством. Лучшие кодеки сегодня - это On2 VP6 и Ateme H.264 (используется в программном пакете Ahead Nero). Кодек H.264 появился относительно недавно и еще очень "сырой". К сожалению качество H.264 еще не достает до качества VP6 и имеет множество глюков, поэтому делать рипы с его помощью пока рано.

    Аудио кодек MP3 также устарел. Сейчас есть очень много кодеков нового поколения, лучшие из которых на мой взгляд - AAC и OGG. Для себя я выбрал кодек AAC. Звук мне кажется наиболее качественным (субъективно конечно).

    В этой статье я подробно опишу процесс создания рипа в формате VP6+AAC (такие рипы нельзя посмотреть на стационарных плеерах с поддержкой MPEG4/DivX/Xvid). Не буду утверждать, что предложенный способ самый простой, но после многочисленных попыток я выбрал для себя именно его.

    1. Установка программ, которые понадобятся для создания рипа.

    Для начала скачайте и установите следующие программы:

    - Кодек On2 VP6
    - Dr. DivX
    - SmartRipper
    - VirtualDub с поддержкой MPEG2
    - Ahead Nero (лучшескачать все три части пакета)
    - AC3 ACM Decompressor by fccHandler
    - PX3's AC3 to WAV

    Для работы с Matroska (новый контейнер наподобие .AVI) необходимо скачать:

    - Matroska Muxer
    - mkvtoolnix
    - AVIMux-GUI

    Все утилиты для работы с Matroska можно скачать здесь. Распакуйте их в одну папку.

    2. Копирование видео с DVD на винчестер (риппинг).

    Откройте программу SmartRipper и вставьте DVD диск с фильмом. После того, как программа прочитает диск, вы увидите это окно:

    Теперь нажмите кнопку Settings и выберите max-filesize в категории File - Splitting, а также введите значение 9900 (например) в поле max-filesize и нажмите кнопку OK. Все это нужно проделать только один раз - SmartRipper навсегда запомнит эти настройки:

    Теперь нажмите вкладку Stream Processing. Снимите все галочки кроме видеодорожки и аудио дорожки с русским звуком. Например:

    В поле Target укажите место, куда вы хотите переписать видео с DVD диска. Убедитесь также, что на жестком диске достаточно свободного места.

    Нажмите кнопку Start и ждите (обычно 20-30 минут). После окончания риппинга выскочит окно.

    Зайдите в папку, которую указали в программе. Вы увидите несколько маленьких по размеру файлов и один большой (размером несколько гигабайт). Это и есть необходимый нам файл, который содержит видео и аудио доржки.

    3. Подготовка аудио дорожки.

    Откройте получившийся видео файл (обычно это vts_01.vob) в программе VirtualDub.

    Для начала, с помощью ползунков отметьте начало и конец фильма. Если в начале фильма есть реклама или что-то в этом духе - смело обрезайте. Я обычно также обрезаю титры в конце фильма - это позволяет повысить битрейт для конечного видео файла и, как следствие, качество рипа будет заметно лучше.

    Выберете Source audio в меню Audio.

    После этого выберете Save WAV... в меню File и укажите место, куда вы хотите сохранить звуковую дорожку. Не закрывайте программу VirtualDub!

    А теперь перейдем к кодированию видео.

    4. Кодирование видео.

    Перекодировать видео необходимо только в два прохода (Two Pass). Только так вы получите качественный рип. Кодирование в один проход - пустая потеря вашего времени.

    Для начала отключим обработку звука. Для этого выберете No audio в меню Audio.

    Перед кодированием видео сначала нужно применить так называемые фильтры. В большинстве случаев нужно установить три фильтра для обработки видео: Deinterlace, Cropping и Resize.

    Для установки фильтров выберете Filtres... в меню Video.

    Фильтр Deinterlace преобразует интерлейсное видео в прогрессивное (убирает эффект "расчестки"). Нажмите кнопку Add..., выберете Deinterlace и нажмите ОК. Затем выберете Blend fields together (best) и нажмите ОК.

    Фильтр Cropping убирает черные полосы. Нажмите кнопку Add... и выберете Null transform. Затем нажмите кнопку Cropping... Откроется окно с фильмом. При помощи ползунка выберете какой-нибудь яркий кадр, чтобы граница между видео и черными полосами была отчетливо видна.

    После этого передвиньте границу между видео и черными полосами так, чтобы полностью закрыть черные полосы. Если черные полосы слева и справа не больше нескольких пикселей, то лучше не передвигать границу в этих местах (в данном случае размер черной полосы слева всего 2 пиксела).

    После этого нажмите ОК.

    Фильтр Resize вытягивает картинку так, чтобы избавиться от эффекта "вытянутых лиц". Для того, чтобы определить "нормальный" размер кадра в фильме, нужно открыть .VOB файл с помощью программы Dr. DivX и нажать Next.

    Размер кадра должен быть кратен 16. Например, ширина обычно имеет размер 720 или 704 пикселя, а высота кадра обычно 288, 304, 384, 400, 480 пикселей.

    Если Dr. DivX показал маленький размер кадра (например 640x288), а видео, переписанное с DVD диска с уже убранными черными полосами, имеет ширину 720 (или 704), то нужно будет самому подсчитать размер кадра. В данном случае (когда ширина кадра 720) примерную высоту можно высчитать по формуле:

    примерная высота кадра = 720 * 288 / 640

    Т.е. будет равна 324 пикселя. Но 324 - число не кратное 16, поэтому придется подыскать подходящее значение очень близкое к 324 (например 320).

    Итак, с размером кадра вы определились. Нажимаем кнопку Add..., выбираем Resize и нажимаем ОК. Затем вводим ширину и высоту видео и выбираем Lanczos3 в меню Filter mode. Снова нажимаем ОК.

    Теперь все три фильтра установлены. Должно получиться примерно следующее:

    Нажимаем ОК и приступаем к настройке кодека.

    Для этого в меню Video выбираем Compression...

    Из появившегося списка кодеков выбираем кодек VP62 Heightened Sharpness Profile и нажимаем кнопку Configure:

    Здесь вы увидите первое окно настройки кодека. Выберете Two Pass - First Pass в меню Mode. Поставьте Local File Playback (VBR) в меню End Usage и Progressive в меню Material. Также введите битрейт для видео.

    Как считается битрейт. Допустим вы хотите сделать DVD рип на один CD диск. Посмотрите какая получилась длительность фильма (с обрезанными титрами). Допустим фильм длится 1 час 40 минут, т.е. 100 минут. Тогда общий битрейт (видео и аудио потока) будет считаться по формуле:

    общий битрейт = 700000 / 100 / 60 * 8

    В данном случае получилось 933 Кбит/c (933 Kbps). Дальше вычитаем битрейт, который вы хотите оставить для аудио дорожки. Например, если вы хотите отдать звуку 56 Кбит/c, то нужно вычесть 56 из 933 (на практике обычно можно вычетать не 56, а 40-50). Т.е. получилось 877. Можете смело округлить до 880. Итак, ставим в поле Bitrate (kilobits per sec) число 880.

    Затем нажимаем вкладку Advanced и переходим ко второй странице настроек кодека.

    Значение Undershoot можно оставить 90. Это значение отлично подходит для большинства фильмов. Ставим галочку Adjust Quantizer и вводим подходящие значения. Если фильм на DVD хорошего качества и он не больше двух часов, то значение Minimum ставьте 1. Это позволит кодеку создать наиболее четкое видео. Для поля Maximum подходят значения 7, 15, 23, 31, 39, 47, 55, 63. Чем ниже значение, тем выше качество. Но значения 7, 15, 23 не подходят для фильмов (их можно попробовать только если вы кодируете с очень высокими битрейтами - 1500 Кбит/с и выше). 31, 39, 47 - хорошие значения для большинства фильмов. Если вы кодируете очень длинный фильм на один диск, то ставьте значение 63.

    Больше ничего не меняем и нажимаем ОК - настройки кодека закрываются. Еще раз жмем ОК.

    В меню File программы VirtualDub выберете Save as AVI...

    В открывшемся окне выберете место, куда будет записан видео файл. Также напишите имя файла (например video.avi) и поставьте галочку Don't run this job now... После этого нажмите кнопку Сохранить.

    Затем снова заходим в настройки кодека и на первой странице настроек меняем Two Pass - First Pass на Two Pass - Second Pass - Best Quality. Остальные поля не трогаем!

    Затем заходим на вторую страницу настроек кодека (вкладка Advanced). Сейчас здесь можно изменить три параметра Variability, Min Section, Max Section. Но в большинстве случаев лучше этого не делать, т.к. настройки по умолчанию работают намного лучше, чем другие настройки, почти для всех фильмов. "Играть" с ними стоит только если вы делаете видео на сверхнизких битрейтах (600 и ниже).

    Дальше жмем ОК. Еще раз ОК. Выбираем Save as AVI... в меню File. Снова ставим галочку и нажимаем Сохранить...

    Итак, теперь все готово для самого кодирования видео. Процесс занимает несколько часов (время кодирования напрямую зависит от производительности процессора). Лучше запускать процесс кодирования на ночь.

    Для запуска процесса выберете Job control... в меню File.

    Для запуска процесса нажмите Start.

    Когда кодирование будет завершено, вы увидите надпись Done для каждого из заданий (всего их два) в строке Status. Это означает, что у вас есть готовый видео файл, но еще без звука.

    5. Кодирование аудио дорожки.

    К этому моменту у вас должна уже быть аудио дорожка. Поменяйте разрешение файла с .wav на .ac3 (для этого ваш Explorer должен показывать разрешения файлов). Откройте программу PX3's AC3 to WAV. Выберете сохраненную в VirtualDub дорожку в поле AC3-File и файл с расширением .wav в поле WAV-File, в который запишется обработанная аудио дорожка. Отметьте галочку normalize WAV file...

    Нажмите Start Convert. В выскочившем окне нажмите ОК и подождите (обычно 1-2 минуты).

    После этого откройте полученный .WAV файл в программе Nero Wave Editor.

    Для того, чтобы перекодировать звук в формат AAC, выберете Save As... в меню File.

    В открывшемся окне выберете тип файла Nero Digital Audio (HE-AAC)(*.mp4) и нажмите Options.

    Сейчас вы видите страницу с настройками аудио кодека AAC. Просто выберете предустановку (вверху) и остальные настройки сами изменятся (изменять их вручную не имеет смысла). Звук CBR использовать не стоит, т.к. VBR гораздо эффективнее. В нашем случае стоит использовать предустановку VBR/Стерео - Компакт, 50-70 Кб/с (HE-AAC). С этой настройкой вы получите звуковую дорожку в формате AAC с переменным битрейтом 56 Кбит/c (56 Kbps).

    Нажмите ОК, напишите имя конечного файла (например sound.mp4) и нажмите сохранить. Через несколько минут вы получите полностью готовую аудио дорожку.

    Теперь осталось только соединить видео и аудио в контейнер Matroska.

    6. Размещение видео и аудио в контейнер Matroska.

    Откройте папку, куда вы распаковали утилиты для работы с Matroska. Запустите программу mmg.exe.

    Перетащите мышкой из Explorer оба файла в программу. Вы увидите, что в поле Tracks добавилось две записи:

    Нажмите Start muxing и подождите (около минуты). Вы получите файл с расширением .MKV. Поздравляю, теперь у вас есть полностью готовый рип в формате VP6+AAC.

    Для удобства можно переименовать получившийся файл и изменить расширение файла с .MKV на .AVI.

    Примечание:
    Для просмотра такого рипа на компьютере должны быть установлены кодеки VP6, Core AAC и Matroska Splitter. Вы можете скачать "мини-пак" с этими кодеками здесь. Если кодеки установились без проблем, то рип можно смотреть в любом программном плеере (Windows Media Player, Media Player Classic, BSPlayer и других).

    Обсудить статью.

    Автор: Alexey (rus)